Aller au contenu


Erreurs lors de login

Bienvenue sur les nouveaux forums. Si vous avez des problèmes pour vous connecter avec votre login, certains caractères spéciaux présents dans les logins ont été modifiés dans le processus de migration, les logins avec les caractères "["
et "]" ont été remplacés par "!" par exemple. Vous pouvez aussi utiliser le formulaire de recouvrement de mot de passe avec votre adresse mail.

Il est également possible que des mots de passes aient été convertis lors de la migration, dans ce cas il vous suffit de redemander un mot de passe pour le réinitialiser.

Merci de votre compréhension ! :love:

[Tuto] installation Serveur tmnforever + aseco sous Linux


  • Veuillez vous connecter pour répondre
200 réponses à ce sujet

#51 OFFLINE   TEMCA

TEMCA

    Il n'est plus un nouveau

  • Membres
  • 84 messages
  • LocationPACA (Var 83)

Posté 18 juillet 2008 - 15:20

Dès que je modifie la playlist, je suis obligé de reboot complètement le serveur, de relancer le serveur trackmania et relancer Aseco (3mn en tout pour faire ça).

Par contre si qq sait comment faire autrement... suis preneur aussi !
Serveur de jeu : Cliquez pour rejoindre TEMCA RacinG CROSS /// Pour les accros des maps de cross...

#52 OFFLINE   papykun

papykun

    Il n'est plus un nouveau

  • Membres
  • 88 messages

Posté 19 juillet 2008 - 03:22

Bonsoir, je suis entrain de peter un cable...





	

		1

		10000

		1

		0

		0

		0

		30

		0

		0

		5

		50

		6

		0

		5

		360000

		0

		5

		0

		100

		5

		3

		2

	


	

		0

		300000

		5

	


	

		1

		0

		0

		0

		1000

		0

		0

	


	2

	

		Campaigns/Nations/Blue/C03-Acrobatic.Challenge.Gbx

		c4oQLgleEPkNtehypwdYXTkmVvi

	

	

		Challenges/Test_ccl_1.Challenge.Gbx

		ekOD7NUyXKNafgeelcgeEpKeUZ0

	

	

		Challenges/Beta_ccl0.Challenge.Gbx

		GMGfF4eo3HzrmmnnLmxiZ5PoR0m

	

	

		Challenges/Beta_CCL2.Challenge.Gbx

		AX_T8BL1vB8kD2IJzEbRS98WOi6

	

	

		Challenges/Beta_CCL1.Challenge.Gbx

		xVDkNP_Vk16gVMS5QljBZFJ_l46

	

	

		Challenges/Beta_CCL1.0.Challenge.Gbx

		ryPpRtbkZdUIusOK4EoyYygeADj

	




360000

J'ai beau l'avoir réglé, qd sa change de map il passe souvent sur une autre valeur... Y'a un autre endroit ou le régler car sa me soul...

#53 OFFLINE   TEMCA

TEMCA

    Il n'est plus un nouveau

  • Membres
  • 84 messages
  • LocationPACA (Var 83)

Posté 19 juillet 2008 - 09:59

Je ne connais pas la config si c'est ton pc qui sert de serveur dédié. Perso j'ai un serveur dédié internet (donc en ligne et accessible 24/24) pour ne pas prendre de la ressource sur mon pc.

Voici mon fichier settings :





	

		1

		1

		12000

		1

		0

		0

		0

		50

		0

		0

		5

		5

		6

		0

		5

		300000

		0

		1

		0

		100

		3

		3

		1

	


	

		0

		300000

		3

	


	

		0

		1

		0

		0

		1000

		0

		1

	


	0

	

		Challenges\My Challenges\09_Trophee-Andros.Challenge.Gbx

		Bt5v8eXkHYoKLumSdDJwI4vDBY6

	

Serveur de jeu : Cliquez pour rejoindre TEMCA RacinG CROSS /// Pour les accros des maps de cross...

#54 OFFLINE   papykun

papykun

    Il n'est plus un nouveau

  • Membres
  • 88 messages

Posté 20 juillet 2008 - 02:44

Je vais regarder mais sa semble "identique" :/

#55 OFFLINE   sylvain1970

sylvain1970

    Nouveau qui a de l'avenir

  • Membres
  • Pip
  • 39 messages

Posté 17 aot 2008 - 11:33

Bonjour,
j'ai un soucis avec l'administration du serveur (local).
J'ai installé TMWeb mais je ne peux pas me connecter car j'ai l'erreur suivante :

Citation

unpack() [function.unpack]: Type V: not enough input, need 4, have 0 (line : 502)
Si qqn avait une solution, merci.

#56 OFFLINE   Centorus

Centorus

    Membre en devenir

  • Membres
  • PipPip
  • 112 messages
  • LocationFrance Nantes

Posté 20 aot 2008 - 12:03

Bonjour,

Je voudrais sauter le pas et passer par un serveur dedié de chez OVH.. pour le moment je loue un serv chez Emengine mais un peu cher à mon gout..

Qd je passe par OVH il me propose différentes distribution de linux et je ne sais pas laquelle prendre.. ensuite est ce que les logiciels style php et le reste sont déja installé sur le dédié ou faut il le faire sois meme... en fait je ne sais meme pas ce que je vais avoir en louant un serveur dédié.... j'ai lu bcp de chose sur les différents forums mais j'aimerais si c possible avoir des réponses si vous le voule bien ^^

Merci d'avances
Image IPB

#57 OFFLINE   brandy

brandy

    Premiers mots

  • Membres
  • 9 messages

Posté 20 aot 2008 - 17:25

moi je n'arrive pas à me connecter au CP....  :/

Et dans le dedicated_cfg, il faut mettre quoi dans le champs key s'il vous plait ?

#58 OFFLINE   papykun

papykun

    Il n'est plus un nouveau

  • Membres
  • 88 messages

Posté 21 aot 2008 - 21:10

Citation

Bonjour,

Je voudrais sauter le pas et passer par un serveur dedié de chez OVH.. pour le moment je loue un serv chez Emengine mais un peu cher à mon gout..

Qd je passe par OVH il me propose différentes distribution de linux et je ne sais pas laquelle prendre.. ensuite est ce que les logiciels style php et le reste sont déja installé sur le dédié ou faut il le faire sois meme... en fait je ne sais meme pas ce que je vais avoir en louant un serveur dédié.... j'ai lu bcp de chose sur les différents forums mais j'aimerais si c possible avoir des réponses si vous le voule bien ^^

Merci d'avances

Bonsoir, contact moi si tu veux des infos. J'ai un serveur chez OVH. Par contre attend le 28 aout et les nouvelles offres.

#59 OFFLINE   sylvain1970

sylvain1970

    Nouveau qui a de l'avenir

  • Membres
  • Pip
  • 39 messages

Posté 22 aot 2008 - 14:11

Bonjour,
donc pour suivre mon pb avec TMWeb (voir message plus haut), j'ai d'autre soucis avec Aseco et remoteCP :

PB Aseco :

Citation

PHP Warning:  Module 'mcrypt' already loaded in Unknown on line 0
# initialize ASECO ############################################################
[Aseco] PHP Version is 5.2.3-1ubuntu6.4
[Aseco] Load settings [config.xml]
[Aseco] Load styles [./styles/standard.xml]
###############################################################################
#
# Aseco v2.1.6 running on localhost:5000
#
# Authors: Florian Schnell and Brad Mettee (RASP)
#
###############################################################################
[Load Plugin] [plugin.localdb.php] [Name] [Ver]
[Load Plugin] [plugin.tmxlinker.php] [Name] [Ver]
[Load Plugin] [plugin.about.php] [Name] [Ver]
[Load Plugin] [plugin.statusbar.php] [Name] [Ver]
[Load Plugin] [plugin.stats.php] [Name] [Ver]
[Load Plugin] [plugin.records.php] [Name] [Ver]
[Load Plugin] [plugin.vote.php] [Name] [Ver]
[Load Plugin] [plugin.score.php] [Name] [Ver]
[Load Plugin] [plugin.example.php] [Name] [Ver]
[Load Plugin] [plugin.help.php] [Name] [Ver]
[Load Plugin] [plugin.emotics.php] [Name] [Ver]
[Load Plugin] [plugin.admin.php] [Name] [Ver]
[Load Plugin] [plugin.plugins.php] [Name] [Ver]
No authitems added
[Aseco] Try to connect to server on localhost:5000
[Aseco] Authenticated with username '******' and password '******'
[-506] Method 'SendHideManialinkPage' not defined
[ASECO Error] Connection could not be established! on line 518 in file /mnt/hda3/sylvain/TMNF/TmDedicatedServer/aseco.php
[08/22,15:00:20] Beginning to shutdown Aseco due to an error ...
J'ai beau vérifier les fichiers de config, je ne trouve pas.

Pour remoteCP :
installation ok
création d'un user ok
activation d'un user ok (j'ai mis du temps à le trouver celui-là)
connexion à remoteCP ok
saisie login/pass ok
et

Citation

[-506] Method 'GetServerPackMask' not defined

remoteCP fatal error
Si qqn à une piste, je suis preneur....

Merci.

Précision : le serveur est chez moi

#60 OFFLINE   floops

floops

    Membre en devenir

  • Membres
  • PipPip
  • 129 messages

Posté 22 aot 2008 - 15:51

Pour ton soucis de connexion à la base de données, dans localdatabase.xml, mets 127.0.0.1 plutot que localhost.

Et pour ce qui est de RemoteCP, utilises tu bien la dernière version du serveur dédié ?
Peut-être que ta version est trop vielle, et n'a donc pas toutes les fonctions.



P.S : Installes la dernière version de PHP, on ne sait jamais ;)
τєρ`Vαcнє <3

#61 OFFLINE   sylvain1970

sylvain1970

    Nouveau qui a de l'avenir

  • Membres
  • Pip
  • 39 messages

Posté 22 aot 2008 - 16:33

Merci des infos.
J'étais justement en train de tout recommencer et çà à l'air de fonctionner.
J'avais bien un problème de version de serveur.

Le serveur fonctionne.
Aseco fonctionne.
RemoteCP4 indique juste :

Citation

Can not find mysql database
pourtant, la base remotecp4 est créée (ainsi que aseco121).
Plus qu'un problème à régler.

#62 OFFLINE   floops

floops

    Membre en devenir

  • Membres
  • PipPip
  • 129 messages

Posté 22 aot 2008 - 17:43

Quelle version de RemoteCP tu utilises ?

Si c'est celle du tuto, je te conseille de passer à la dernière version, qui te permets d'exploiter la base de données d'Aseco.

RemoteCP-4.0.2.2

Lors du 1er lancement, il va te demander de l'installer, si c'est pas le cas, tu appelles le fichier :

http://monsite.fr/Re...P-4/install.php

Tu tombes sur :

Image IPB

La case qui nous interesse est celle entourée de rose.
Il faut mettre dans cette case :

default_with_asecodb

Vu que ton serveur et et RemoteCP sont sur la même machine, tu n'as pas besoin de cocher la partie FTP.

Par contre il faut que tu coches Enable dans la partie SQL, et que tu entres tes identifiants et le nom de la base de données d'Aseco.

Le reste je pense que tu devrais pouvoir t'en débrouiller.

Bon courage ;)
τєρ`Vαcнє <3

#63 OFFLINE   papykun

papykun

    Il n'est plus un nouveau

  • Membres
  • 88 messages

Posté 22 aot 2008 - 19:35

Je suis entrain de modifié, avec les nouvelles versions justement, mais je test donc sa me fera gagner du temps tes infos floops.

Merci

#64 OFFLINE   sylvain1970

sylvain1970

    Nouveau qui a de l'avenir

  • Membres
  • Pip
  • 39 messages

Posté 22 aot 2008 - 20:11

ok, merci, çà progresse vite avec ton aide.
J'avais la version 4.0.2.1.

Encore une petite erreur avec remoteCP (4.0.2.2) :

Citation

[remoteCP-4 Warning] [-506] Method 'IsRelayServer' not defined on line 173 in file /mnt/cheminversledossier/remoteCP_4-0-2-2/includes/system.plugins.php

question supplémentaire, comment passer en timeattack (il est toujours en round) ?

Merci.

EDIT : il y d'autres erreurs (peut-être induites de la première)

Citation

[remoteCP-4 Warning] Table 'aseco121.rs_votes' doesn't existSELECT (SELECT SUM(Score) FROM rs_votes WHERE ChallengeId = a.Id)+0 AS Score FROM challenges AS a WHERE a.Uid = 'eDgWjoKe2dT3GfoTCGCmI_qMvfk' on line 515 in file....
la table "votes" est dans la base.

Aseco est indispensable car il y a aseco et remoteCP comme base (ou il faut les 2) ?

2e EDIT : j'ai trouvé pour le timeattack

#65 OFFLINE   floops

floops

    Membre en devenir

  • Membres
  • PipPip
  • 129 messages

Posté 23 aot 2008 - 11:15

Pour la 1ere erreur,

[remoteCP-4 Warning] [-506] Method 'IsRelayServer' not defined on line 173 in file /mnt/cheminversledossier/remoteCP_4-0-2-2/includes/system.plugins.php

A quelle moment apparait-elle ?

---------------------------------------------------------------------------

Pour la 2eme, RemoteCP cherche rs_votes, alors que la table n'as pas de prefix, elle se nomme juste votes.
L'erreur se trouve ligne 515, mais c'est pas complet, on ne voit pas quand quel fichier, merci de le préciser.
Vérifie tout de même dans le fichier xml/settings/default_with_asecodb/database.xml, qu'à la fin ce ressemble à ça :


	

		Id

		PlayerId

		ChallengeId

		Score

	


τєρ`Vαcнє <3

#66 OFFLINE   sylvain1970

sylvain1970

    Nouveau qui a de l'avenir

  • Membres
  • Pip
  • 39 messages

Posté 24 aot 2008 - 07:47

Salut,
pour la 1ère erreur : elle est un peu partout après saisie du login+pass :
en entête, en entête de chat, de overview, de ...., enfin un peu partout.
Mais elle n'a pas l'air de bloquée la gestion, je peux changer de map, faire du chat, modifier les réglages, etc...
Mais c'est moche et j'aimerai bien corriger (heu, que l'on m'indique comment faire).

pour la 2e : merci beaucoup, il était bien indiqué table="rs_votes" dans le fichier indiqué, celle-ci est corrigée.

#67 OFFLINE   brandy

brandy

    Premiers mots

  • Membres
  • 9 messages

Posté 25 aot 2008 - 18:21

Comme je vois que ca parle beaucoup de RemoteCP je voudrais savoir comment rajouter un admin IG pour aseco.

De plus j'ai la même erreur:

Citation

[remoteCP-4 Warning] [-506] Method 'IsRelayServer' not defined on line 173 in file /var/www/remoteCP/includes/system.plugins.php

Par contre quand je vais dans l'onglet database et que je veux consulter quelque chose, rien ne s'affiche...

Merci de m'aider  :roll:  :oops:

#68 OFFLINE   sylvain1970

sylvain1970

    Nouveau qui a de l'avenir

  • Membres
  • Pip
  • 39 messages

Posté 26 aot 2008 - 12:02

Salut,
tiens tiens, mon serveur était visible puisqu'il y avait des joueurs.
il ne l'est plus maintenant.
:( (et je ne sais pas pourquoi)

EDIT : çà s'en va et çà revient, c'est fait de.....

Faut peut-être couper/relancer le serveur pour qu'il réapparaisse (c'est ce que je viens de faire et il est revenu dans la liste) ?
Va falloir que je fasse du script alors...

#69 OFFLINE   kimi3

kimi3

    Respectable Ancien

  • Membres
  • PipPipPipPipPipPip
  • 1 270 messages
  • LocationSud Seine-et-marne

Posté 26 aot 2008 - 13:43

bonjour juste une petite question où est-ce qu'on range le dossier de aseco ?
Image IPB

#70 OFFLINE   brandy

brandy

    Premiers mots

  • Membres
  • 9 messages

Posté 26 aot 2008 - 14:59

aseco se trouve dans /usr/games/tmnf/ il est décompréssé la dedans.

#71 OFFLINE   kimi3

kimi3

    Respectable Ancien

  • Membres
  • PipPipPipPipPipPip
  • 1 270 messages
  • LocationSud Seine-et-marne

Posté 26 aot 2008 - 16:08

Merci  [merci]
Image IPB

#72 OFFLINE   brandy

brandy

    Premiers mots

  • Membres
  • 9 messages

Posté 26 aot 2008 - 18:01

Et quelqu'un à une idée de comment on fait pour rajouter un admin pour aseco ?

#73 OFFLINE   toff*****

toff*****

    Premiers mots

  • Membres
  • 4 messages

Posté 31 aot 2008 - 14:00

Pas moyen d'avoir aseco.
Voici le message du log :

PHP Warning:  mime_magic: type regex BEGIN[[:space:]]*[{] application/x-awk invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\input text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\section text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\setlength text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentstyle text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\chapter text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentclass text/x-tex invalid in Unknown on line 0
X-Powered-By: PHP/4.4.8_pre20070816-pl1-gentoo
Content-type: text/html



Parse error:  syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /usr/games/tmnf/aseco.php on line 114


#74 OFFLINE   js

js

    Membre en devenir

  • Membres
  • PipPip
  • 108 messages
  • LocationSan Francisco - USA (CA)

Posté 01 septembre 2008 - 11:04

Citation

Pas moyen d'avoir aseco.
Voici le message du log :

PHP Warning:  mime_magic: type regex BEGIN[[:space:]]*[{] application/x-awk invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\input text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\section text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\setlength text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentstyle text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\chapter text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400 \\documentclass text/x-tex invalid in Unknown on line 0
X-Powered-By: PHP/4.4.8_pre20070816-pl1-gentoo
Content-type: text/html



Parse error:  syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /usr/games/tmnf/aseco.php on line 114

Si j'ai bien compris ! Tu tournes avec PHP 4.4.8 (?) Or Aseco nécéssite PHP5 car il est totalement codé en objet. Or l'Objet n'est pas disponible sous PHP4 ... Essaye de migrer sous Php5
[SA.fr]JS

www.thesharkteam.com

ServerAdmin:
NATIONS SPEED ADDICTION

#75 OFFLINE   js

js

    Membre en devenir

  • Membres
  • PipPip
  • 108 messages
  • LocationSan Francisco - USA (CA)

Posté 01 septembre 2008 - 11:05

Citation

Et quelqu'un à une idée de comment on fait pour rajouter un admin pour aseco ?

tu dois remplir les fichiers config.xml (les champs LOGIN_DU_JOUEUR) et faire de même pour admingroups.xml
:roll:
[SA.fr]JS

www.thesharkteam.com

ServerAdmin:
NATIONS SPEED ADDICTION




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)