Aller au contenu


Erreurs lors de login

Bienvenue sur les nouveaux forums. Si vous avez des problèmes pour vous connecter avec votre login, certains caractères spéciaux présents dans les logins ont été modifiés dans le processus de migration, les logins avec les caractères "["
et "]" ont été remplacés par "!" par exemple. Vous pouvez aussi utiliser le formulaire de recouvrement de mot de passe avec votre adresse mail.

Il est également possible que des mots de passes aient été convertis lors de la migration, dans ce cas il vous suffit de redemander un mot de passe pour le réinitialiser.

Merci de votre compréhension ! :love:

[Adminserv] Contrôleur Web Pour Serveur Dédié - V2


  • Veuillez vous connecter pour répondre
162 réponses à ce sujet

#101 OFFLINE   N@no

N@no

    Membre en devenir

  • Membres
  • PipPip
  • 126 messages

Posté 17 septembre 2010 - 22:34

Rien à dire niquel mise à part ce petit bug quand je clique sur Guest/Ban

Citation

Warning: simplexml_load_file() [function.simplexml-load-file]: /home/xxxx/servers/xxxxx/server/GameData/Config/dedicated_cfg.log:1: parser error : Start tag expected, '<' not found in /home/xxx/www/xxxxx/includes/adminserv.class.php on line 825

Warning: simplexml_load_file() [function.simplexml-load-file]: X-Powered-By: PHP/5.2.5-pl1-gentoo in /home/xxxxxx/www/adminserv/includes/adminserv.class.php on line 825

Warning: simplexml_load_file() [function.simplexml-load-file]: ^ in /home/xxxxx/www/adminserv/includes/adminserv.class.php on line 825

Fatal error: Call to a member function getName() on a non-object in /home/xxxxx/www/adminserv/includes/adminserv.class.php on line 830

Image IPB

#102 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 18 septembre 2010 - 08:57

Je n'ai pas réussi à reproduire ton erreur, mais j'ai quand même corrigé, à voir si ça fonctionne ;)

#103 OFFLINE   Dolly

Dolly

    Premiers mots

  • Membres
  • 7 messages

Posté 19 septembre 2010 - 09:25

Bonjour,

j'ai cette erreur quand je clique sur Guest-Ban en dessous de Playlist
Fatal error: Call to a member function getName() on a non-object in /home/www-data/ipsite/adminserv/includes/adminserv.class.php on line 830

Pour info, je suis sous Debian avec php 5.3.3
Paf Dolly

#104 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 19 septembre 2010 - 12:27

J'ai mis à jour AdminServ ;)

Ca corrige les erreurs lorsqu'il y a d'autres fichiers txt dans le dossier Config du dédié.

#105 OFFLINE   Dolly

Dolly

    Premiers mots

  • Membres
  • 7 messages

Posté 19 septembre 2010 - 15:09

Merci pour la correction de mon erreur [clap]
Paf Dolly

#106 OFFLINE   detruire56

detruire56

    Nouveau qui a de l'avenir

  • Membres
  • Pip
  • 35 messages

Posté 05 octobre 2010 - 19:02

Bonjours, j'ai un problème, quand je me connect sur AdminServ (Sous hébergement, je sais pas si c'est important), je mes mon mpd SuperAdmin
puis apres sa me met:
- ERREUR: Le serveur n'est pas accessible -

voila dans la config:

/* SERVERS */

	$i = 0;

	

	$server[$i]['name']					= 'BZH Serveur';															// Server name

	$server[$i]['address']				= '90.54.27.195';															// Server address

	$server[$i]['port']					= 5002;															// XMLRPC port

	$server[$i]['match_settings']		= '';															// Default MatchSettings

	$server[$i]['admin_level']			= array('SuperAdmin' => null, 'Admin' => null, 'User' => null);	// Admin level list

	$server[$i]['onyx_webservice']		= array('', '', 9900);											// Onyx webservice : 1:Username, 2:Password, 3:REST port

	$server[$i]['other_management']		= array(false, '');												// Other management of Onyx : 1:true or false, 2:Path of plugins.xml file

	$i++;

	/*
Une solution ???
Venez postez :==>ICI<==

#107 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 06 octobre 2010 - 07:33

Adminserv est sur quel type d'hébergement ?

#108 OFFLINE   detruire56

detruire56

    Nouveau qui a de l'avenir

  • Membres
  • Pip
  • 35 messages

Posté 06 octobre 2010 - 10:36

Par FTP et sur lescigales.org
Venez postez :==>ICI<==

#109 OFFLINE   externe

externe

    Nouveau en confiance

  • Membres
  • 14 messages

Posté 09 octobre 2010 - 18:34

perso j'utilise adminserv pour tous mes serveurs et franchement c'est genial

même pour les serveur que je loue en cooper comme ca , ca permet au locataire d'avoir une page admin pour gérer eux même leur serv
un grand GG a toi kev717 [clap]  [clap]

#110 OFFLINE   PonoP

PonoP

    Premiers mots

  • Membres
  • 5 messages

Posté 30 octobre 2010 - 14:37

Bonjour a tous :)

Tout d'abord un grand bravo a toi kev717 :D

Cependant j'ai un gros problème, je ne peux plus accéder a adminserv. hier ça marchait super bien quand je l'ai installé, et depuis ce matin pas moyen d'y accéder :/ je rentre pourtant bien localhost/adminserv et firefox charge la page continuellement. Pourrais-tu m'aider s'il te plaît ? :s

Merci d'avance :)

#111 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 30 octobre 2010 - 16:40

Tu utilise wamp ? si oui, tu as bien lancé wamp avant ? Sinon vérifie que ton serveur dédié est accessible dans le jeu.

#112 OFFLINE   PonoP

PonoP

    Premiers mots

  • Membres
  • 5 messages

Posté 30 octobre 2010 - 19:04

Oui j'utilise wamp, j'ai fait tout comme il fallait j'ai suivi a la lettre ton tutorial ...

http://www.onyx-team...torials&video=0

hier ça marchait niquel, localhost/adminserv marchait aussi.
aujourd'hui seul adminserv ne marche pas :/

help :'(

#113 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 30 octobre 2010 - 21:37

Tu n'utilise pas Skype par hasard ? Si oui -> http://forum.onyx-te...topic.php?id=97

#114 OFFLINE   PonoP

PonoP

    Premiers mots

  • Membres
  • 5 messages

Posté 30 octobre 2010 - 22:12

Pas de skype sur mon PC.

#115 OFFLINE   strapy

strapy

    Il n'est plus un nouveau

  • Membres
  • 92 messages

Posté 30 octobre 2010 - 22:46

Salut,
Comment faire pour sauvegarder les réglages du serveur fait sur adminserv ? (sauvegarder Grace a adminserv)

#116 OFFLINE   PonoP

PonoP

    Premiers mots

  • Membres
  • 5 messages

Posté 31 octobre 2010 - 09:04

Kevin ....

Je n'ai strictement rien fait/modifié et ...

ça remarche

I love Windows Vista -_-"

Désolé de t'avoir dérangé ^^'
Cependant, j'ai remarqué une difference. L'aiguille de wampserveur etait aux trois quarts hier et ce matin elle est vraiment tout en bas.

A bientot ! ;)

#117 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 31 octobre 2010 - 10:11

Ok
@strapy : adminserv ne sauvegarde que les gameinfos/challenges. Les options serveur ne sont pas sauvegardé. Il faut configurer le fichier dedicated.cfg du serveur dédié pour ça.

#118 OFFLINE   PonoP

PonoP

    Premiers mots

  • Membres
  • 5 messages

Posté 31 octobre 2010 - 10:21

Ce que dit strapy m'interesse aussi. je fouille le dedicated.cfg, et je ne trouve pas les modifications a apporter ... eclaircis-nous, kev \o/

#119 OFFLINE   j@ck

j@ck

    Nouveau en confiance

  • Membres
  • 16 messages

Posté 02 novembre 2010 - 03:32

Avant tout bonjour et félicitation a Kev pour ce boulot superbe.

Je debute dans le monde TMN et possede 1 serveur KIMSUFI de cher ovh ou je cree des serveurs cod4, cod5 et depuis peus tmnf.

Jusque la tout allais bien (2 serveurs en ligne tmn)

Je decide d installer ADMINSERV, nikel sa fonctionne du premier coup (magnifique et d' une simplicité :D )

Le problemes est quand je rajoute le 2 emes serveurs avec les ports differents evidamment, sa me met erreur,impossible d etablir une connection avec le serveur.

Tout mon fichier config est correcte pourtant :

premier serv: port 500  xmlrpc 2450 et l autre 3450 par default je pense et la tout est ok

2 emes serveurs:  port 5002   xml 2452  et l autre 3452  et la impossible d etablir une connection avec le serveur

Cela fai 3 jours que je cherche et essaye et impossible d'y arriver.

En espérent de l aide de votre part je vous souhaite une bonne soirée

PS: petite precision mon serveur hebergement ou est ADMINSERV n est pas sur la meme machine que le jeus. (hebergement web ovh) et cela fonctionnent pour le serv1 mes pas pour l' autre     bizare :(

#120 OFFLINE   titou266

titou266

    TrackManiaque

  • Membres
  • PipPipPip
  • 397 messages

Posté 02 novembre 2010 - 08:07

Pour moi, c'est une simple erreur de redirection.
T'as mis la bonne IP ? le 5002 n'est pas déjà utilisé par ton serv cod ? Sinon, en changeant 5002 par 5003, ca devrait le faire .

#121 OFFLINE   j@ck

j@ck

    Nouveau en confiance

  • Membres
  • 16 messages

Posté 02 novembre 2010 - 13:18

Salut et merci de ton aide

je vien de tester 4 fois avec des prts differents et toujour un echec. (le serveur demarre bien mes impossible de si connecter avec ADMINSERV

voici mon fichier config en etant arriver avec le port 5005:

/********************* SERVER CONFIGURATION *********************/

/* SERVERS */
$i = 0;

$server[$i]['name'] = 'serv1'; // Server name
$server[$i]['address'] = '188.165.210.51'; // Server address
$server[$i]['port'] = 5000; // XMLRPC port
$server[$i]['match_settings'] = ''; // Default MatchSettings
$server[$i]['admin_level'] = array('SuperAdmin' => null, 'Admin' => null, 'User' => null); // Admin level list
$server[$i]['onyx_webservice'] = array('', '', 9900); // Onyx webservice : 1:Username, 2:Password, 3:REST port
$server[$i]['other_management'] = array(false, ''); // Other management of Onyx : 1:true or false, 2:Path of plugins.xml file
$i++;

$server[$i]['name'] = 'serv2'; // Server name
$server[$i]['address'] = '188.165.210.51'; // Server address
$server[$i]['port'] = 5005; // XMLRPC port
$server[$i]['match_settings'] = ''; // Default MatchSettings
$server[$i]['admin_level'] = array('SuperAdmin' => null, 'Admin' => null, 'User' => null); // Admin level list
$server[$i]['onyx_webservice'] = array('', '', 9900); // Onyx webservice : 1:Username, 2:Password, 3:REST port
$server[$i]['other_management'] = array(false, ''); // Other management of Onyx : 1:true or false, 2:Path of plugins.xml file
$i++;





/********************* OPTIONAL CONFIGURATION *********************/

/* GENERAL */
$title1 = 'Admin';
$title2 = 'Serv';
$slogan = 'For trackmania servers';
$logo = 'logo_server.png';
$theme_default = 'Blue'; // Blue, Orange, Green, Violet, Black
$language = 'FR'; // Available language : FR, EN, DE, ES

/* ADVANCED */
$cookie_expire = 15; // Number of days after they cookies expire
$secondtool = array(false, ''); // Second tool : 1:true or false, 2:url of redirect, if null -> automatic redirect
$limit_players_list = 250; // Limit display for the player list
$limit_challenges_list = 1000; // Limit display for the challenge list
$challenge_max_size = 5; // Size max of challenge to upload
$recent_status_period = 86400; // Period in second for display "recent" status : 86400 = 3600x24 = 24h
$autosave_matchsettings = true; // Enable default automatic back up

/* URL DIRECTORY */
$url_images = './images/'; // Can change location of folder "images", "includes" and "styles".
$url_includes = './includes/';
$url_styles = './styles/';

?>

le serv1 ses nikel sa fonctionne mes le serv 2 voici le message d erreur:

- ERREUR: Le serveur n'est pas accessible -

Je ne vois vraiment pas quoi faire :(

#122 OFFLINE   j@ck

j@ck

    Nouveau en confiance

  • Membres
  • 16 messages

Posté 02 novembre 2010 - 13:59

Voila enfin trouver mon erreur  (de ma faute evidamment)

mon fichier dedicated_cfg.txt du jeus j avais mis :

True  et j ai remplacer le True par False et le tour est jouer

tout est ok et un grand merci de l aide :D

a bientot

#123 OFFLINE   moosei53

moosei53

    Premiers mots

  • Membres
  • 1 messages

Posté 05 novembre 2010 - 15:12

bonjour,

Je souhaiterais telecharger adminserv mais malheureusement j'ai l'impression que le site est en rideaux

QQ aurais un lein pour que je puisse le télécharger
merci d'avance

#124 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 05 novembre 2010 - 15:44

Je suis en train de changer d'hébergement, c'est en cours de transfert ;)

#125 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 08 novembre 2010 - 18:30

C'est de nouveau disponible ;)




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)