Aller au contenu


Erreurs lors de login

Bienvenue sur les nouveaux forums. Si vous avez des problèmes pour vous connecter avec votre login, certains caractères spéciaux présents dans les logins ont été modifiés dans le processus de migration, les logins avec les caractères "["
et "]" ont été remplacés par "!" par exemple. Vous pouvez aussi utiliser le formulaire de recouvrement de mot de passe avec votre adresse mail.

Il est également possible que des mots de passes aient été convertis lors de la migration, dans ce cas il vous suffit de redemander un mot de passe pour le réinitialiser.

Merci de votre compréhension ! :love:

[Adminserv] Contrôleur Web Pour Serveur Dédié - V2


  • Veuillez vous connecter pour répondre
162 réponses à ce sujet

#26 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 17 janvier 2010 - 11:26

Merci  :wink:

Tu as un mot de passe différent entre chaque serveur ?
Tu utilise quoi comme navigateur ?

#27 OFFLINE   floops

floops

    Membre en devenir

  • Membres
  • PipPip
  • 129 messages

Posté 17 janvier 2010 - 15:38

J'ai le même soucis au niveau du switch serveur. J'utilise Chrome 3 et IE 8, idem sur les deux. (le mot de passe est le même pour tous les serveurs)

En tout cas beau travail. C'est très clair, on ne peut plus rapide, facile à utiliser. GG  [clap]
τєρ`Vαcнє <3

#28 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 17 janvier 2010 - 18:54

Exact, faudra que je corrige ça, merci d'avoir signalé  :wink:

#29 OFFLINE   floops

floops

    Membre en devenir

  • Membres
  • PipPip
  • 129 messages

Posté 17 janvier 2010 - 18:58

Le onclick sur un "option" effectivement ne fonctionne pas. J'ai essayé en passant un onchange sur le select, mais je n'arrive pas à récupérer la variable du serveur. (this.value)
C'est peut être une piste à explorer.
τєρ`Vαcнє <3

#30 OFFLINE   chdanao

chdanao

    Il n'est plus un nouveau

  • Membres
  • 93 messages

Posté 17 janvier 2010 - 19:24

reBonjour,

Pour ma part, j'utilise firefox, j'ai 3 serveurs avec des mdp différents.

A+ bon courage!

#31 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 17 janvier 2010 - 20:01

Si tu utilise des mdp différents, tu sera redirigé vers la page de login. Je pourrait récup le mot de passe avec l'id du serveur dans le switch serveur, mais si celui qui à acces à un serveur n'a pas le droit d'avoir accès aux autres (car il y a d'autres mdp -> donc accès restreint) et bien il pourrait quand même y avoir accès. (je suis clair ?  :? )


EDIT:

Citation

Le onclick sur un "option" effectivement ne fonctionne pas. J'ai essayé en passant un onchange sur le select, mais je n'arrive pas à récupérer la variable du serveur. (this.value)
C'est peut être une piste à explorer.

Effectivement, la solution était bien un onchange sur le select, merci ;)

#32 OFFLINE   -Blade-

-Blade-

    Sage de la communauté

  • Membres
  • PipPipPipPipPipPipPipPip
  • 2 660 messages
  • LocationAsile pf'z cellule #69

Posté 18 janvier 2010 - 16:18

Salut Kev, voilà chez ROXSERVERS on a l'intention d'utiliser adminserv, en test au début puis si c'est satisfaisant le mettre à la place de tmweb à moyen terme.
Donc je te fais remonté une info de mon boss, ou notre principale souci est qu'on autorise pas l'accès au fichier php pour des raisons de sécurités.

Citation

Concernant AdminServ vu que ça a été demandé le problème est que contrairement à TMWeb il faut tout préconfigurer dans un fichier PHP. Pour TMWeb ça récupérait tout seul les infos nécessaires et ça te demande juste ton mot de passe que ça compara avec celui de ton serveur avant de te laisser entrer ou non.

Avec adminserv tout est "figé" car tu dois tout préconfigurer donc en gros si les serveurs sont livrés avec adminServ, celui-ci va marcher 3 minutes car dès que l'utilisateur va changer le mot de passe admin apr exemple adminserv ne saura plus se connecter.
Si tu connais le gars qui l'a développé tu peux peut être lui soumettre l'idée de s'inspirer de TMWeb pour la partie login et réglages de config afin de simplifier la chose.
Dans le pire des cas j'essaierai de coder une page de login rapidement mais ça va être super lourd car à chaque fois faudra que l'utilisateur entre diverses infos ce qui rend le login pénible.

Donc voilà en attente d'une réponse.

Amicalement Blade.
Image IPB
Image IPB
Image IPB

#33 OFFLINE   ImHoTep

ImHoTep

    Membre en devenir

  • Membres
  • PipPip
  • 154 messages
  • LocationSt Esprit (972)

Posté 18 janvier 2010 - 19:33

D'apres ce que j'ai vu la config d'adminserv se fait de la meme facon que TMWeb, c'est a dire les infos de connection necessaires sont dans le fichier config.php, y a rien d'automatique a moins que quelqu'un a modifie ton TMWeb pour que cela marche de facon automatique
CT*ImHoTep
Image IPB
Le jour où l'on mettra les cons sur orbite, y en a qui n'ont pas fini de tourner ...

#34 OFFLINE   tof25

tof25

    TrackManiaque

  • Membres
  • PipPipPip
  • 253 messages

Posté 18 janvier 2010 - 20:19

La différence c'est que dans adminserv le mot de passe superadmin du serveur est dans le config.php, et c'est un autre mot de passe qui est utilisé pour l'accès a adminserv, alors que dans tmweb le mot de passe d'accès est directement celui du superadmin du serveur
Posted Image

#35 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 19 janvier 2010 - 00:43

Non en fait j'avais pas pensé à ça ^^
Je verrai pour changer le système de login dans la prochaine version  :wink:

#36 OFFLINE   ImHoTep

ImHoTep

    Membre en devenir

  • Membres
  • PipPip
  • 154 messages
  • LocationSt Esprit (972)

Posté 19 janvier 2010 - 01:30

Citation

La différence c'est que dans adminserv le mot de passe superadmin du serveur est dans le config.php, et c'est un autre mot de passe qui est utilisé pour l'accès a adminserv, alors que dans tmweb le mot de passe d'accès est directement celui du superadmin du serveur

Je n'avais pas regarde en detail le source, juste vu que dans config.php il y avait les memes chose que pour tmweb :wink:
CT*ImHoTep
Image IPB
Le jour où l'on mettra les cons sur orbite, y en a qui n'ont pas fini de tourner ...

#37 OFFLINE   norico

norico

    Membre en devenir

  • Membres
  • PipPip
  • 136 messages

Posté 21 janvier 2010 - 00:34

Bon voila, j'ai passer des sources a Kevin pour la gestion des plugins d'Xaseco.
Dans la prochaine version j'espère. ^^

#38 OFFLINE   Ov6rMinD

Ov6rMinD

    Membre en devenir

  • Membres
  • PipPip
  • 153 messages

Posté 30 janvier 2010 - 00:01

Salut à tous !

Je suis le créateur de TMWeb, qui, comme vous l'avez remarqué, commence à dater (il était fait pour TMNations). J'ai appris beaucoup de choses depuis ce dev... Les dernières MAJ ne sont même pas de moi :D

Je suis content que qqn reprenne le flambeau (je passais ici par curiosité, en me demandant si il était nécessaire de re-développer TMWeb (en entier). Et là je tombe sur un outil PHP, je le regarde de plus près (screenshot et deux fichiers PHP) et je vois une interface claire, des classes PHP, que du bonheur quoi :)

Bravo et continuez ! Bonne chance pour la suite,

Jean-Matthieu DECHRISTÉ
Webmaster du site http://www.pcreation.fr
et http://joomla.tmweb.123.fr <- Interfaces Web pour vos serveurs TM !

#39 OFFLINE   Ov6rMinD

Ov6rMinD

    Membre en devenir

  • Membres
  • PipPip
  • 153 messages

Posté 30 janvier 2010 - 00:01

Au fait, y'a encore bcp de mecs qui gèrent des serveurs ?
Webmaster du site http://www.pcreation.fr
et http://joomla.tmweb.123.fr <- Interfaces Web pour vos serveurs TM !

#40 OFFLINE   Husi10

Husi10

    Sage de la communauté

  • Membres
  • PipPipPipPipPipPipPipPip
  • 2 530 messages
  • Location404 not found

Posté 30 janvier 2010 - 00:06

Lance TMforever et regarde le nombre de serveurs ;)
Image IPB

#41 OFFLINE   titou266

titou266

    TrackManiaque

  • Membres
  • PipPipPip
  • 397 messages

Posté 30 janvier 2010 - 02:55

Over > Oaip, et vu le nombres d'applications, de requests dispos, on a pas fini de gerer des serveurs pour les petits trackmaniaques :p .

#42 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 30 janvier 2010 - 11:54

Hop !

La nouvelle version 1.1 est disponible !  [yes]

Les nouveautés :
    *  Ajout du niveau d'administration à la connexion (Superadmin, Admin ou User)
    * Administration plus complexe (forceScores, changeAuthPasswd, etc) sur general
    * Configuration simplifiée (Suppression de login & passwd)
    * Ajout de la gestion des plugins pour Xaseco en local
    * Ajout de la gestion des challenges/playlists en local
    * Ajout de la nouvelle version de jQuery 1.4
    * Correction des valeurs à virgules sur gameinfos
    * Correction du statistique "Démarré depuis"
    * Correction du switch serveur
    * Divers ajouts et corrections
    * Diverses modifications CSS & Javascript
    * Traduction en anglais

Merci à tous les bêta testeurs (Koko, Beurkman, Norico, Fadden)
Si il y a des intéressés pour traduire AdminServ en Allemand ou autres, me contacter par MP ;)

Pour télécharger toujours sur le site -> http://www.zone-kev717.info/adminserv/

Et aussi une nouvelle page "Installation" sur le site pour vous aidez dans la configuration d'AdminServ.

Merci à tous  [merci]

#43 OFFLINE   ImHoTep

ImHoTep

    Membre en devenir

  • Membres
  • PipPip
  • 154 messages
  • LocationSt Esprit (972)

Posté 30 janvier 2010 - 14:24

[clap]  [clap] C'est deja vachement mieux  [yes]  [yes]
C'est presque parfait, pour moi il ne manque qu'une chose.
Quand tu edites un matchsetting que tu recuperes en local, il faudrait avoir la possibilité de modifier le game info, tu vas me dire mais ca y est deja dans le menu game infos, mais non, celui la sert pour le game infos en cours sur le serveur, le mieux c'est de faire une nouveau menu pour la gestion de matchsetting a cote de challenges (je ne sais pas si je suis clair)

Admin Server va etre la reference maintenant  :wink:

edit: tu as un pb de positionnement dans challenge et que tu choisis ajout local, si il y a bcp de repertoires la partie gauche ( css .tab_left)  se retrouve en dessous de la partie droite (css .tab_right)
CT*ImHoTep
Image IPB
Le jour où l'on mettra les cons sur orbite, y en a qui n'ont pas fini de tourner ...

#44 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 30 janvier 2010 - 15:40

Citation

edit: tu as un pb de positionnement dans challenge et que tu choisis ajout local, si il y a bcp de repertoires la partie gauche ( css .tab_left)  se retrouve en dessous de la partie droite (css .tab_right)

Pourtant ça devrait pas vu qu'il y a une largeur fixe. Chez moi j'ai pas ce problème ...
Tu utilises quel navigateur ? Je viens de tester sous Firefox, Chrome, IE8 et Opera, et il n'y a pas de problème.  :wink:

#45 OFFLINE   ImHoTep

ImHoTep

    Membre en devenir

  • Membres
  • PipPip
  • 154 messages
  • LocationSt Esprit (972)

Posté 30 janvier 2010 - 16:10

sous FF 3.5.6
Image IPB
CT*ImHoTep
Image IPB
Le jour où l'on mettra les cons sur orbite, y en a qui n'ont pas fini de tourner ...

#46 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 30 janvier 2010 - 16:16

Et sous la 3.6, c'est pareil ?

#47 OFFLINE   ImHoTep

ImHoTep

    Membre en devenir

  • Membres
  • PipPip
  • 154 messages
  • LocationSt Esprit (972)

Posté 30 janvier 2010 - 16:44

Je n'ai encore pas installe 3.6 encore (et la j'ai un download en cours)
par contre c'est pareil avec IE8
Tu as mis width="380" pour "" mais les tables augmente leur taille si une cellule est plus grande, et comme c'est le seul endroit ou tu indiques une taille dans le tableau il s'agrandit. (euh pourquoi un
au fait ?)
En Apparté (parce que ce n'est pas genant)  tu declares un DOCTYPE en xhtml strict, or ce n'est pas vraiment le cas
CT*ImHoTep
Image IPB
Le jour où l'on mettra les cons sur orbite, y en a qui n'ont pas fini de tourner ...

#48 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 30 janvier 2010 - 17:53

J'étais pourtant persuadé d'avoir mis une taille en largeur sur le div des dossiers, mais non  :-o

J'ai mis à jour le fichier, essayes et dis moi ;)

#49 OFFLINE   Fadden

Fadden

    TrackManiaque

  • Membres
  • PipPipPip
  • 282 messages
  • LocationPlus ou moins à l'ouest

Posté 30 janvier 2010 - 19:01

Hmmm très bien cette nouvelle version. Avec l'ajout de map locale en plus c'est vraiment cool ! Bon un petit séparateur entre les noms des dossiers ne serait pas de refus ;)

Il y a le même "problème" que 4LTurbo a remarqué, dans l'onglet général, cadre infoserveur quand le nom du serveur est assez long toutes les infos partent en dessous de leur libellé. Bon c'est pas trop grave faut vraiment que le nom soit long^^

Et il y a une fonctionnalité que j'ai cherché il y a quelques jours et que je n'ai pas trouvé : la possibilité d'arrêter le serveur.

Voilà génial truc quoi, et très agréable à utiliser  [clap]
Elle est où la poulette ?

#50 OFFLINE   kev717

kev717

    Membre d

  • Membres
  • PipPipPipPip
  • 610 messages
  • LocationLa Rochelle

Posté 30 janvier 2010 - 19:17

Merci !

Pour le nom du serv, ça devrait pas décaler non plus ... :(

Citation

Et il y a une fonctionnalité que j'ai cherché il y a quelques jours et que je n'ai pas trouvé : la possibilité d'arrêter le serveur.

C'est possible, mais il y en a vraiment beaucoup qui utilise ce genre de commande ? quand faut stopper un serv, il faut généralement le redémarrer, donc on fait ça directement sur le serveur concerné. C'est vraiment utile pour toi ? ^^




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)