Aller au contenu


Erreurs lors de login

Bienvenue sur les nouveaux forums. Si vous avez des problèmes pour vous connecter avec votre login, certains caractères spéciaux présents dans les logins ont été modifiés dans le processus de migration, les logins avec les caractères "["
et "]" ont été remplacés par "!" par exemple. Vous pouvez aussi utiliser le formulaire de recouvrement de mot de passe avec votre adresse mail.

Il est également possible que des mots de passes aient été convertis lors de la migration, dans ce cas il vous suffit de redemander un mot de passe pour le réinitialiser.

Merci de votre compréhension ! :love:

Problème Aseco


  • Veuillez vous connecter pour répondre
3 réponses à ce sujet

#1 OFFLINE   Trackmania2

Trackmania2

    Il n'est plus un nouveau

  • Membres
  • 74 messages

Posté 28 fvrier 2016 - 17:34

Bonjour,

J'essaye de configurer un serveur Trackmania Sunrise et je suis à la dernière étape, celle où on installe Aseco.
Je "pense" avoir tout bien fait correctement mais lorsque je lance le Aseco.bat j'ai ça :

# initialize ASECO ############################################################
...Load settings [config.xml]
...Load plugin [plugin.localdatabase.php]
...Load plugin [chat.admin.php]
...Load plugin [chat.help.php]
...Load plugin [chat.me.php]
...Load plugin [chat.records.php]
...Load plugin [chat.stats.php]
...Load plugin [chat.vote.php]
...Try to connect to server on 127.0.0.1:5005
...Authenticate on server with username '********' and password '*********'
...Connection established successfully!
...Try to connect to MySQL server
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in C:\Users\Arthur\Documents\TMS\TmDedicatedServer\ASECO\plugins\plugin.localdatabase.php:32
Stack trace:
#0 C:\Users\*****\Documents\TMS\TmDedicatedServer\ASECO\aseco.php(551): db_connect(Object(Aseco), Array)
#1 C:\Users\******\Documents\TMS\TmDedicatedServer\ASECO\aseco.php(174): Aseco->releaseEvent('onstartup', Array)
#2 C:\Users\*******\Documents\TMS\TmDedicatedServer\ASECO\aseco.php(1111): Aseco->run()
#3 {main}
  thrown in C:\Users\*******\Documents\TMS\TmDedicatedServer\ASECO\plugins\plugin.localdatabase.php on line 32
Appuyez sur une touche pour continuer...

Si vous pouviez m'éclairer sur ce sujet ça serait cool :)
J'avais aussi planifié d'installer Fast 3.1 sur mon serveur dédié qui pour moi est plus simple à configurer que Aseco mais je n'ai trouvé aucun lien de téléchargement, si quelqu'un d'entre vous pouvait me le passer ça serait cool aussi x)

Merci d'avance

#2 OFFLINE   Trackmania2

Trackmania2

    Il n'est plus un nouveau

  • Membres
  • 74 messages

Posté 28 fvrier 2016 - 17:50

En fait j'ai 2 versions de PHP, la version 5.6.16 et la 7.0.0

Quand je met 7.0.0 ça m'affiche ce qu'il y a au dessus mais lorsque je met le 5.6.16 ça fait :
# initialize ASECO ############################################################
...Load settings [config.xml]
...Load plugin [plugin.localdatabase.php]
...Load plugin [chat.admin.php]
...Load plugin [chat.help.php]
...Load plugin [chat.me.php]
...Load plugin [chat.records.php]
...Load plugin [chat.stats.php]
...Load plugin [chat.vote.php]
...Try to connect to server on 127.0.0.1:**********
...Authenticate on server with username '*********' and password '*********'
...Connection established successfully!
...Try to connect to MySQL server
[PHP Warning] mysql_connect(): MySQL server has gone away on line 32 in file C:\Users\*******\Documents\TMS\TmDedicatedServer\ASECO\plugins\plugin.localdatabase.php
[PHP Warning] mysql_connect(): Error while reading greeting packet. PID=15260 on line 32 in file C:\Users\**********\Documents\TMS\TmDedicatedServer\ASECO\plugins\plugin.localdatabase.php
[PHP Warning] mysql_connect(): MySQL server has gone away on line 32 in file C:\Users\********\Documents\TMS\TmDedicatedServer\ASECO\plugins\plugin.localdatabase.php
[ASECO Error] Could not authenticate at MySQL server! on line 33
Appuyez sur une touche pour continuer...


#3 OFFLINE   Mimile38

Mimile38

    TrackManiaque

  • Membres
  • PipPipPip
  • 319 messages
  • LocationIsère

Posté 04 mars 2016 - 21:51

Bonjour,
D'après les logs, je pense qu'il faut que tu restes avec la version 5.6.16, mais vérifie dans le fichier localdatabase.php que tu as bien mis :
<mysql_server>localhost</mysql_server>
<mysql_login>root</mysql_login>
<mysql_password>MOT DE PASSE</mysql_password>
<mysql_database>NOM DE TA BDD</mysql_database>

Sachant que le mot de passe est complètement facultatif quand tu héberges ton serveur en local sur ton PC. Si tu n'en as pas configuré, laisse la balise vide.

#4 OFFLINE   Trackmania2

Trackmania2

    Il n'est plus un nouveau

  • Membres
  • 74 messages

Posté 04 mars 2016 - 23:34

Salut Homer et merci pour ta réponse :)
Oui j'ai tout bien rempli avec la BDD et le mot de passe.
Par contre j'ai mis localhost:8080 car j'ai modifié le port de connexion pour wamp (j'avais un conflit du port 80 avec IIS)
J'ai également vu sur phpmyadmin l'extension MySQL appelée mysqli j'ai remplacé tout les mysql du localdatabase.php par mysqli et voyant que ça ne changeait rien j'ai annulé les modifications.




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)