Aller au contenu


Erreurs lors de login

Bienvenue sur les nouveaux forums. Si vous avez des problèmes pour vous connecter avec votre login, certains caractères spéciaux présents dans les logins ont été modifiés dans le processus de migration, les logins avec les caractères "["
et "]" ont été remplacés par "!" par exemple. Vous pouvez aussi utiliser le formulaire de recouvrement de mot de passe avec votre adresse mail.

Il est également possible que des mots de passes aient été convertis lors de la migration, dans ce cas il vous suffit de redemander un mot de passe pour le réinitialiser.

Merci de votre compréhension ! :love:

Serveur Sur Windows 10 ?


  • Veuillez vous connecter pour répondre
14 réponses à ce sujet

#1 OFFLINE   ccx

ccx

    Il n'est plus un nouveau

  • Membres
  • 79 messages
  • LocationParis (92)

Posté 11 mai 2016 - 22:41

Bonjour,

J'ai un serveur qui tourne depuis des années sur XP avec 2 Go de RAM. J'ai investi sur un PC d'occase W7 avec 8Go, j'attends une autre barette de 8Go pour passer à 16.

D'où mes deux questions :

* Puis-je faire tourner mon serveur (XAMP + Xaseco) sous W10, ou dois-je l'installer sur W7 ?

* Mon serveur actuel, avec + de 1500 maps et 100 records/map commence a avoir du mal a manipuler la base SQL, d'où l'upgrade sur un nouveau serveur avec de la RAM.
=> Windows va la gérer sans que j'ai rien a faire, ou il y a des astuces à connaitre pour charger des tables en mémoire, ou allouer plus de RAM à certaines tâches ?

Question subsidiaire : bien que connecté 24/24, je n'ai jamais mis d'anti-virus dessus, puis-je continuer, avec un W7 ou W10 ?
(EDIT) Oops, je ne trouve pas de XAMPP en 64 bits ? Ca n'existe pas ??
(EDIT, bis) Je ne trouve pas sur SourceForge ou ApacheFriends mais sur Clubic, si....

Merci !

ccx.

Modifié par ccx, 11 mai 2016 - 23:08.

Go go go !!

#2 OFFLINE   Trackmania2

Trackmania2

    Il n'est plus un nouveau

  • Membres
  • 74 messages

Posté 14 mai 2016 - 18:31

Je ne vois pas pourquoi ça ne marcherait pas sous Win10 :ph34r:
Un Windows ça fonctionne de la même manière qu'un autre :ph34r:

Pour l'allocation de RAM ça se fait automatiquement, sauf si tu veux régler toi même le taux de RAM que doit utiliser Xampp...
Un antivirus n'est jamais obligatoire, sauf si tu veux en installer un, comme tu veux...
Tout est à savoir si tu as un système 64bits ou 32bits, et de toute façon ça ne pose aucun problème d'installer un programme 32 bits sur un système 64bits... Si tu veux à tout prix avoir un programme 64bits va télécharger WampServer c'est une alternative à Xampp.
Si t'as trouvé sur Clubic, bah c'est bien, même si je pense que c'est pour faire plus vendeur car le 32bits marche aussi avec un 64bits. Si ils te demandent pas de télécharger le 32 ou 64 et que tu passes direct au téléchargement tu t'es fait avoir...

A+

PS : ton serveur est sur quel TM ?

#3 OFFLINE   ccx

ccx

    Il n'est plus un nouveau

  • Membres
  • 79 messages
  • LocationParis (92)

Posté 15 mai 2016 - 18:41

Merci de me répondre.
Je quitte XP pour ajouter de la RAM, je suis donc sur un Windows 64 bits (W7) car W 32 ne gère que 3 Go maxi. Finalement, j'ai repris le même Xampp que précédemment, comme ça je n'avais pas a refaire toute la config.

!!! Attention : j'ai trouvé un Xampp 64 bits pour Windows, hébergé chez Google, ne pas le charger, c'est n'est qu'un nid de virus et autres MaleWare !!! (Moi qui n'avais pas d'anti-virus, ça a un peu piqué ^_^)

Mon serveur est TM 1 (Stadium).
Depuis mon premier post, j'ai recopié la config de mon serveur XP sur mon nouveau PC sous W7 (Adresse IP, nom de la carte réseau, compte utilisateur..) Le serveur marche pour les autres : je vois sur la console qu'ils se connectent, tandis que moi, non ?! C'est quoi ce binz ?! Au niveau du routeur, vu l'IP est la même, je n'ai rien à faire, la config pare-feu de Windows est la même.
La différence est que je passe d'un Système d'Exploitation 'family' à un 'pro'.

D'autres ont-ils un serveur sous W7 "Professional' hébergé chez eux, et si oui, arrivent-ils à s'y connecter ?

Merci !

ccx.
Go go go !!

#4 OFFLINE   Tati Trini

Tati Trini

    Guide de la nation TM

  • Gentils Modérateurs
  • PipPipPipPipPipPipPipPipPipPip
  • 17 804 messages
  • LocationAu bord de la mer...

Posté 15 mai 2016 - 23:28

Bonsoir. :D

http://forum.trackma...-mode-internet/ ;)
Faq et Wiki à lire avant de poser une question.  

Focus ! Nadeo ! We love you ! Trackmania Forever and ever !

Image IPB

#5 OFFLINE   ccx

ccx

    Il n'est plus un nouveau

  • Membres
  • 79 messages
  • LocationParis (92)

Posté 16 mai 2016 - 01:39

Coucou Tati,

Merci pour le lien, mais je l'ai lu avant de me permettre de poster ma question.
Dès le début, Slig dit :

Citation

Si, pour une raison ou une autre, ces solutions ne fonctionnement pas pour vous, 3 choix :

- jouer en "réseau local", sans ladder.
- acheter un routeur-nat qui gère les redirection de ports normalement

- mettre le serveur TM sur une autre machine (Win XP ou linux)

Pour rappel, le même serveur (que j'ai changé pour un PC plus récent et un S.E. plus récent aussi) fonctionnait parfaitement il y a encore 2 jours, mises à part des lenteurs à cause de la base SQL qui commence à grossir...

Il parle de Win XP, d'où ma question, est-ce que sous W7 Pro je suis sensé pouvoir me connecter à mon serveur depuis ce même PC, ou un autre de mon réseau ? (mon PC 'client' est sous W10 Famille, et mon serveur sous W7 Pro. J'ai besoin de me connecter aussi depuis mon serveur à TM car une macro fait rentrer chaque matin tous mes comptes sur mon serveur, juste histoire de toucher mes 240 coppers / jour... c'est que ça coûte, la FreeZone ;))

Merci pour vos lumières (passer à W7 Famille ? en version Pro, il a fallu que j'indique dans la config réseau que le PC n'est pas dans un bureau, mais dans une résidence..)

ccx.
Go go go !!

#6 OFFLINE   Tati Trini

Tati Trini

    Guide de la nation TM

  • Gentils Modérateurs
  • PipPipPipPipPipPipPipPipPipPip
  • 17 804 messages
  • LocationAu bord de la mer...

Posté 16 mai 2016 - 10:58

le tuto date de.... 2007... :lol:
il n'y a pas de raison que la version de windaube influe le résultat (sauf win10... :P ). par contre, as-tu coupé l'uac de 7? et 7 a 2 pare-feux donc tu dois faire tes ouvertures de ports dans les 2. ;)
Faq et Wiki à lire avant de poser une question.  

Focus ! Nadeo ! We love you ! Trackmania Forever and ever !

Image IPB

#7 OFFLINE   ccx

ccx

    Il n'est plus un nouveau

  • Membres
  • 79 messages
  • LocationParis (92)

Posté 16 mai 2016 - 13:03

Je sais que c'est un vieux tuto.. il m'a déjà grandement servi dans ma jeunesse :) (Voir en p.7, en bas de la page j'avais mis mon grain de sel en 2011 ;) )

J'ai installé CCleaner pour nettoyer la base de registre, et le cache et tout et tout, à chaque reboot (programmé toutes les nuits). A chaque fois, y compris au démarrage du PC, Windows me demandait l'autorisation de lancer CCleaner.

Donc j'ai fini par virer l'UAC   (Tu parles bien de mettre le curseur au plus bas "Ne jamais m'avertir" ? Xampp conseille d'ailleurs ce choix.)

Quant au pare-feu, j'y ai pensé, j'ai tenté de couper les 2 (2 ? Privé + Public, c'est bien ça ?) mais toujours pareil. Par contre quand j'ai coupé les pare-feu, je n'ai pas rebooté ?

Y a t'il un tuto pour configurer ces foutus pare-feu ? Je n'y connais pas grand-chose à ce sujet, je trouve que la présentation dans XP était plus claire ...

Quand tu dis

Citation

Il n'y a pas de raison que la version de windaube influe le résultat (sauf win10...)
que veux-tu dire ? J'arriverais plus facilement à me connecter à mon serveur si j'upgradais en W10, ou au contraire ce n'est pas conseillé ?

Merci pour les réponses, car là j'ai une dizaine de joueurs connectés, et moi je n'arrive pas à aller voir si ça marche mieux qu'avant ou pas.. grr (en plus, je kiffe mes maps ^_^)

ccx.

Modifié par ccx, 16 mai 2016 - 13:09.

Go go go !!

#8 OFFLINE   Tati Trini

Tati Trini

    Guide de la nation TM

  • Gentils Modérateurs
  • PipPipPipPipPipPipPipPipPipPip
  • 17 804 messages
  • LocationAu bord de la mer...

Posté 16 mai 2016 - 13:35

uac: yep donc ok.
win10: crosoft décide ce qui bon pour toi... donc jouer à TM n'est pas dans la liste... :P  oublie le!
pare-feu 1: dans la page du pare-feu de 7, à gauche tu as une ligne "autoriser un programme....". dedans autorise tout ce qui est lié à TM (jeu, serveur...).
pare-feu 2: dans la page du pare-feu de 7, à gauche tu as une ligne "paramètres avancés". dedans autorise tout ce qui est lié à TM (jeu, serveur...) dans "règles de trafic entrant" et "règles de trafic sortant".
puis reboote le pc et teste. ;)
Faq et Wiki à lire avant de poser une question.  

Focus ! Nadeo ! We love you ! Trackmania Forever and ever !

Image IPB

#9 OFFLINE   ccx

ccx

    Il n'est plus un nouveau

  • Membres
  • 79 messages
  • LocationParis (92)

Posté 17 mai 2016 - 23:29

Bonsoir,

Alors hier j'ai désactivé les 2 pare feu du serveur. Rebooté.. idem.
Ce soir, extinction du serveur, du client, et de la box, pendant une bonne heure.
Rallumage : exactement pareil : "Echec de connexion serveur. Connection to 86.242.yyy.xx:12353 failed or disconnected from server (10060)" .. sur le serveur et le client.

Je pense qu'il reste 2 pistes :
Supprimer le paramétrage de la box, et le ressaisir.
Ou passer à W7 family ? (J'essaye d'accéder de mon PC en W10 à mes dossiers du serveur W7 Pro, je n'y arrive pas, ça bloque de partout (apparemment il faut mettre un mot de passe sur le User du serveur... c'était plus simpe en XP ! Dossier / Partager, et roule !)

Qu'en pense Tati ?

Merci !
Go go go !!

#10 OFFLINE   Tati Trini

Tati Trini

    Guide de la nation TM

  • Gentils Modérateurs
  • PipPipPipPipPipPipPipPipPipPip
  • 17 804 messages
  • LocationAu bord de la mer...

Posté 18 mai 2016 - 10:13

que ta question est bonne... :P

chaque pc a un mot de passe réseau crée lors de l'installation de seven.
dans chaque pc, tu dois faire ce que j'ai écrit au dessus.
et dans ta box, ouvre des plages de ports et non des ports uniques. ;)
Faq et Wiki à lire avant de poser une question.  

Focus ! Nadeo ! We love you ! Trackmania Forever and ever !

Image IPB

#11 OFFLINE   du02

du02

    Guide de la nation TM

  • Membres
  • PipPipPipPipPipPipPipPipPipPip
  • 7 968 messages
  • Location92XXX

Posté 18 mai 2016 - 13:25

Ce n'est plus une bonne question, mais une bonne solution. ^_^
Vénérateur accompli de skubidou
Image IPB

#12 OFFLINE   ccx

ccx

    Il n'est plus un nouveau

  • Membres
  • 79 messages
  • LocationParis (92)

Posté 18 mai 2016 - 22:01

Coucou,
Peut-être que le tuto de Slig date .. mais je crois qu'il répondait dès le début à une question.

Citation

Attention
- Si les prérequis ci dessus ne sont pas effectifs, alors ça ne peut de toute manière pas marcher en mode internet pour vous non plus !  En aucun cas ça n'aidera à faire fonctionner votre serveur dédié !!!
- Le seul intérêt de ces "trucs" sont d'essayer d'avoir les points ladder qui fonctionnent aussi pour le joueur local au serveur. Donc si vous n'êtes pas accro au ladder alors laissez tomber, et jouez en réseau local, tout simplement.
- à priori ça ne marche pas pour un serveur sous Vista ou Win7, qui apparemment en voulant être "intelligents" empêchent de mettre sa propre ip publique en alias ip sur la carte de la machine.

Mea culpa, je n'y avais pas prêté assez d'attention en premières lectures.
J'en reviens à la question ; est-ce que quelqu'un a pu démontrer que l'à priori peut être dépassé, et qu'on peut jouer sur son serveur depuis son réseau à la maison ?

Merci !
Go go go !!

#13 OFFLINE   Mimile38

Mimile38

    TrackManiaque

  • Membres
  • PipPipPip
  • 319 messages
  • LocationIsère

Posté 13 juin 2016 - 17:19

Si tu affectes à ton serveur des ports différents de ceux utilisés par le jeu, il n'y a pas de raisons que tu ne puisses pas jouer à ton serveur sur le même PC. Je le fais des fois chez moi, ça fonctionne autant en mode "réseau local" qu'en mode multijoueur, comme si on se connectait sur n'importe quel serveur.

#14 OFFLINE   ccx

ccx

    Il n'est plus un nouveau

  • Membres
  • 79 messages
  • LocationParis (92)

Posté 15 juin 2016 - 04:52

Bonjour Homer,
Merci pour ta réponse, peux tu me préciser sous quel OS est ton serveur ?
Ccx.
Go go go !!

#15 OFFLINE   Mimile38

Mimile38

    TrackManiaque

  • Membres
  • PipPipPip
  • 319 messages
  • LocationIsère

Posté 15 juin 2016 - 13:58

Windows 10 ;)




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)