Aller au contenu


Erreurs lors de login

Bienvenue sur les nouveaux forums. Si vous avez des problèmes pour vous connecter avec votre login, certains caractères spéciaux présents dans les logins ont été modifiés dans le processus de migration, les logins avec les caractères "["
et "]" ont été remplacés par "!" par exemple. Vous pouvez aussi utiliser le formulaire de recouvrement de mot de passe avec votre adresse mail.

Il est également possible que des mots de passes aient été convertis lors de la migration, dans ce cas il vous suffit de redemander un mot de passe pour le réinitialiser.

Merci de votre compréhension ! :love:

[TUTO]Se connecter à son serveur dédié en mode internet


  • Veuillez vous connecter pour répondre
178 réponses à ce sujet

#26 OFFLINE   Njones03

Njones03

    TrackManiaque

  • Membres
  • PipPipPip
  • 409 messages

Posté 06 septembre 2007 - 17:09

alors n'ayant pas d'ip fixe pour le net...

je jongle ( ou j'essai) toutes les 24 heures...

aujourd'hui mon ip  91.165.142.246 et pour le pc jeux ( ip lan 192.168.1.3 ) en suivant ton tuto j'ai mis  91.165.142.247.
Notre Forum : VSK Team
ManiaLink : vsk
    Image IPB

#27 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 10 septembre 2007 - 14:19

Ok, essayons de reprendre le problème par le bon bout...  :)

Refais la manip, et quand tu as le message de conflit d'adresse, tu vérifie toutes les ip (et masques réseau) de toutes les machines et tu les indique ici, comme ça on y verra peut être plus clair.

#28 OFFLINE   Njones03

Njones03

    TrackManiaque

  • Membres
  • PipPipPip
  • 409 messages

Posté 12 septembre 2007 - 19:15

ok...merci...mais actuellement je suis en deplacement donc pas avant une bonne semaine

Merci...pour l'aide
Notre Forum : VSK Team
ManiaLink : vsk
    Image IPB

#29 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 14 septembre 2007 - 13:08

envoi moi plutot les infos par mp quand tu retestera, ca évitera de flooder trop le topic ;)

#30 OFFLINE   rafmos

rafmos

    Nouveau en confiance

  • Membres
  • 26 messages

Posté 11 octobre 2007 - 22:14

Pour l'instant chez moi ça ne fonctionne pas. Mais peut-être qu'il faut juste que je redémarre mon matériel ou que j'attende un peu. Je n'ai pas d'adresse ip public fix. J'aimerais juste savoir si ce que j'ai fait est juste :

Sur serverMania :
Image IPB

Sur le jeu :
Image IPB

Sur la carte réseau :
Image IPB

Si ça vous aide, comme vous pouvez le voir, je suis sous Windows Vista. Le serveur et le jeu sur le même pc. Plus tard j'aimerais l'avoir sur 2 mais pour l'instant, on va rester la. Est-ce que j'ai configuré juste ?

Pour le script de l'adresse ip, je suis preneur.  :D

#31 OFFLINE   rafmos

rafmos

    Nouveau en confiance

  • Membres
  • 26 messages

Posté 12 octobre 2007 - 13:09

En fait quand je met l'ip, ça me met aussi cette erreur-là :

Image IPB

Je ne sais pas si j'ai fait juste. Est-ce quelqu'un peut me dire si c'est juste ce que j'ai fait ?

#32 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 12 octobre 2007 - 18:39

Citation

En fait quand je met l'ip, ça me met aussi cette erreur-là :

Image IPB

Je ne sais pas si j'ai fait juste. Est-ce quelqu'un peut me dire si c'est juste ce que j'ai fait ?
Ca semble juste. Enfin à priori rien à voir, mais toujours laisser le 'Forcer adresse serveur' à 0.0.0.0 : 0 (ou vide, je ne sais plus, sauf cas vraiment particulier (et une connexion domestique n'est pas un cas particulier dans le cas présent).

D'autre machine sur le réseau ?  s'il y a un conflit d'adresse, c'est qu'un autre interface réseau connectée a déjà l'adresse, donc soit tu as mis aussi cette adresse à une autre machine (ben là à toi de rectifier le tir), soit tu as une box bizarre (auquel cas rien à y faire sauf si c'est modifiable dans sa config), quel FAI ?
Ou alors c'est Vista qui fait des trucs curieux, mais je ne peux pas tester.

#33 OFFLINE   rafmos

rafmos

    Nouveau en confiance

  • Membres
  • 26 messages

Posté 12 octobre 2007 - 19:26

Pour le "Forcer adresse serveur", c'est bon. En fin je suis pas sûr si je dois laisser le port :

Image IPB

Pour le conflit d'adresse ip, vient quand je met l'ip publique. Pour le masque de sous réseau pour l'adresse publique, c'est juste : 255.255.255.0 ? Je n'étais justement pas sûr ca par défaut il me met 255.0.0.0 et dans ton exemple, tu as mit 255.255.255.0. L'autre, la 192.168.1.35, je l'avait déjà mise avant en fixe et ça fonctionnait très bien.

Mon routeur est Un zyxel 660 Prestige. Pour le FAI, je suis chez Sunrise (c'est en Suisse).

#34 OFFLINE   rafmos

rafmos

    Nouveau en confiance

  • Membres
  • 26 messages

Posté 13 octobre 2007 - 10:37

En fait, c'est bon. J'ai même pas besoin de mettre l'adresse ip publique. En fait il faut pas cliquer sur "internet", quand on est dans le jeu, il faut cliquer sur "Réseau local" et là, on voit notre serveur.  :D

Quand même un petit problème, j'ai installé Onyx, et quand je suis en local, il ne me met pas les record, donc mes points n'augmentent pas. Peut-on changer ça ?

#35 OFFLINE   Cyrlaur

Cyrlaur

    Sage de la communauté

  • Membres
  • PipPipPipPipPipPipPipPip
  • 2 950 messages

Posté 13 octobre 2007 - 12:14

Euh le but du topic c'est justement de donner des solutions pour passer par "Internet" et pas "Réseau Local" hein ... d'où ton problème et le titre du topic :-o
Image IPB

#36 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 13 octobre 2007 - 13:28

Citation

En fait, c'est bon. J'ai même pas besoin de mettre l'adresse ip publique. En fait il faut pas cliquer sur "internt", quand on est dans le jeu, il faut cliquer sur "Réseau local" et là, on voit notre serveur.  :D

Quand même un petit problème, j'ai installé Onyx, et quand je suis en local, il ne me met pas les record, donc mes points n'augmentent pas. Peut-on changer ça ?
Comme dit cyrlaur, bien sur qu'en local ca marche, le but ici était de proposer un truc pour ceux qui tiennent absolument à avoir le ladder qui fonctionne sur leur serveur.
Pour les scripts, je crois que seul Fast3.1 propose d'origine le moyen d'avoir ses records en se connectant en réseau local (il faut renseigner le fichier LANlogins.tmu.xxxx.xml.txt qui est créé automatiquement par fast normalement avec le vrai login correspondant au pseudo utilisé)

#37 OFFLINE   rafmos

rafmos

    Nouveau en confiance

  • Membres
  • 26 messages

Posté 13 octobre 2007 - 14:39

Mais alors pourquoi ça marche pas chez moi en mode Internet ? Je vois mon serveur, mais je n'arrive pas à me connecter dessus : Erreur classique : "-16001" (quelque chose comme ça).

Aidez-moi !!  :(

#38 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 14 octobre 2007 - 13:34

Citation

Mais alors pourquoi ça marche pas chez moi en mode Internet ? Je vois mon serveur, mais je n'arrive pas à me connecter dessus : Erreur classique : "-16001" (quelque chose comme ça).
En mode internet ça marche très bien avec un routeur "normal".
Pour les autres, c'est précisément le sujet de ce tuto, et je ne vois pas en quoi on peut t'aider plus que ce qui est déjà écrit dans ce topic. Relis et reteste, ou bien achète un routeur ne posant pas de problème. Et sinon tant pis, surtout que de toute manière en n'ayant en plus pas une ip fixe...

#39 OFFLINE   FoldMachine

FoldMachine

    Premiers mots

  • Membres
  • 6 messages

Posté 17 octobre 2007 - 12:46

[EDIT]

Bonjour à tous!

Ceci est mon premier post et pour l'occasion je ne poserai pas de question mais essaierai d'apporter une réponse  :D

J'ai donc eu le même problème que tout le monde: la connection sur son propre serveur.
Problème maintenant résolu, ce qui suit explique comment.

Trop la flemme pour les screenshots, on va essayer d'être précis quand même.

Précisions avant de commencer:
- pour les manips d'adresse IP, j'ai simplement utilisé la méthode de l'OP.
- mon routeur est un vieux netgear RP114  [yes]
- serveur et jeu sont sur le même pc
- les IP sont fausses, pas d'intrusion !  :lol:
_____________________________________________________________

Paramétrage IP/réseau (voir le post initial pour la méthode)

- Adresse IP LAN       : 192.168.1.4 (pc sur le réseau)
- Adresse IP publique : 82.220.165.10 (adresse de connection/du modem)
  (juste la trouver, ne jamais la modifier)
- Adresse ajoutée    : 82.220.165.11 (sur le pc hein!)
  (modifier dans les propriétés réseau, TCP/IP)
_____________________________________________________________

Paramétrage Servermania (pour TMN)

  Onglet "Network"

  - Server Port : 2350
  - P2P Port    : 3450
  - Client Port : (vide)
  - Xml-Rpc Listen Port : 5220

  Cocher Force Server IP address
  Décocher Auto Detect Net IP
   Renseigner adresse : 82.220.165.11
_____________________________________________________________

Paramétrage Trackmania nations

  Configure > Advanced > Network

  - Server Port : 2352
  - P2P Server Port : 3452
  - Client Port 443
  - Force Server Addr : 0.0.0.0 : 2350
_____________________________________________________________

Redirection des ports (sur le vieux routeur)

  - 2350 vers 82.220.165.11
  - 3450 vers 82.220.165.11
  - 5220 vers 82.220.165.11
  -   443 vers 82.220.165.11
_____________________________________________________________

J'ai également effectué une Static Route (dans l'admin du routeur bien sûr)

  - Destination IP Address : 82.220.165.11
  - IP Subnet Mask         : 255.255.255.0
  - Gateway IP Address     : 192.168.0.4
  - Metric                 : 0
_____________________________________________________________

Voila, ici ça marche, connection sur mon propre serveur.

Je précise que j'ai écrit ce post, tout excité d'avoir trouvé au bout de 2 jours de bidouille, donc je ne sais pas si les ladders fonctionnent, mais à priori oui.
Et il n'y a aucune valeur scientifique à ce paramétrage, ça marche ici, tout ce que je peux dire  :D


Bonne chance à tous!

#40 OFFLINE   rafmos

rafmos

    Nouveau en confiance

  • Membres
  • 26 messages

Posté 17 octobre 2007 - 13:11

Ca m'a l'air pas mal. Si c'est juste ce que tu dis, c'est que j'ai fait quelque chose de faux. Il faudra que j'essaie quand je serai à la maison. Est-ce que c'est vraiment juste qu'il faut rediriger les ports 2350, 3450, 5220 et 443 vers l'adresse ip publique (82.220.165.11) et non pas du réseau (192.168.1.4) ?

Pour les prpriétés réseau :tcp/ip, il faut bien mettre l'adresse ip publique +1 ? Ton adresse publique est : 82.220.165.10 et tu écris 82.220.165.11 dans le masque ci-dessous ? (l'image de droite, après avoir cliqué sur "ajouter")

Image IPB

#41 OFFLINE   FoldMachine

FoldMachine

    Premiers mots

  • Membres
  • 6 messages

Posté 17 octobre 2007 - 15:28

Citation

Ca m'a l'air pas mal. Si c'est juste ce que tu dis, c'est que j'ai fait quelque chose de faux. Il faudra que j'essaie quand je serai à la maison. Est-ce que c'est vraiment juste qu'il faut rediriger les ports 2350, 3450, 5220 et 443 vers l'adresse ip publique (82.220.165.11) et non pas du réseau (192.168.1.4) ?

Pour les prpriétés réseau :tcp/ip, il faut bien mettre l'adresse ip publique +1 ? Ton adresse publique est : 82.220.165.10 et tu écris 82.220.165.11 dans le masque ci-dessous ? (l'image de droite, après avoir cliqué sur "ajouter")

Image IPB

Non, j'ai redirigé les ports cités (assignés au serveur) pour qu'il contacte l'ip ajoutée et non pas l'IP LAN ou l'IP publique.
J'ai fait la Static Route en me disant : "si quelqu'un veut atteindre 82.220.165.11 (IP créée), alors le rediriger sur 192.168.0.4"
Du moins c'était mon raisonnement.
(EDIT: et comme dans servmania, tu as dit que l'IP était celle créée, les clients vont tenter de se connecter à celle-ci)

Pour l'adresse que tu créés, ici j'ai fait +1 mais ce qui compte c'est d'être dans la même plage (+2 ok, +3 ok, etc...)

#42 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 17 octobre 2007 - 19:13

Je ne pense pas que dans beaucoup de BiduleBox on puisse ajouter une route statique.

Par ailleurs, t'es sur que les autres peuvent se connecter sur ton serveur ??? parce que vu que avec :
Cocher Force Server IP address
Décocher Auto Detect Net IP
Renseigner adresse : 82.220.165.11
tu dis à ton serveur d'enregistrer cette ip au master, or vu que c'est pas l'adresse de ta connexion logiquement les autres ne devraient pas pouvoir joindre.

#43 OFFLINE   FoldMachine

FoldMachine

    Premiers mots

  • Membres
  • 6 messages

Posté 17 octobre 2007 - 19:39

Ben écoute je sais pas si on peut se connecter, je le lance pdt un moment, c'est :"Special Noob!"

Je suis d'accord que les autres vont essayer de me joindre sur 82.220.165.11, mais justement la route statique de 82.220.165.11 vers 192.168.0.4 ne fait-elle pas la redirection?

#44 OFFLINE   FoldMachine

FoldMachine

    Premiers mots

  • Membres
  • 6 messages

Posté 17 octobre 2007 - 19:51

Citation

tu dis à ton serveur d'enregistrer cette ip au master.

Je ne suis pas sûr de comprendre ce que ça veut dire, tu pourrais m'expliquer? :)

#45 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 19 octobre 2007 - 18:24

Citation

Je suis d'accord que les autres vont essayer de me joindre sur 82.220.165.11, mais justement la route statique de 82.220.165.11 vers 192.168.0.4 ne fait-elle pas la redirection?
le problème, c'est que seul ton routeur le sait ça, or cette ip est soit inutilisée, soit celle du routeur d'un de tes voisins de nra/dslam. Donc si une connexion de l'extérieur cherche à joindre cette adresse, c'est à celui-ci que la connexion arrivera, et pas à ton routeur, donc forcément ça ne marche pas.


Citation

Citation


tu dis à ton serveur d'enregistrer cette ip au master.

Je ne suis pas sûr de comprendre ce que ça veut dire, tu pourrais m'expliquer? :)
Quand tu clique un nom de serveur dans la liste du jeu, ton jeu va essayer de se connecter à l'ip que le master lui a indiquée pour le serveur en question. La question est donc, comment le master détermine l'ip du serveur ?

Tout simplement, quand le serveur s'enregistre au master (au démarrage puis plus ou moins régulièrement par la suite), par défaut le master considère quel'ip qu'il "voit" sur cette connexion (http/https) est l'ip du serveur, et l'enregistre donc comme telle. Quand on indique un ip forcée, alors le serveur dit au master "ne considère pas mon ip apparente, mais celle que je t'indique ici". Il n'y a donc aucune raison de faire ça dans les cas normaux, en gros ce n'est utile que si la connexion http/https du serveur passe par un proxy dont l'ip est différente de l'ip à utiliser pour joindre ton serveur.

#46 OFFLINE   FoldMachine

FoldMachine

    Premiers mots

  • Membres
  • 6 messages

Posté 20 octobre 2007 - 08:49

Ok, je comprends mieux, c'est le mot "master" qui bloquait un peu.

Ce que tu dis est tout à fait logique.

j'avais fait les réglages +/- à l'arrache donc si ça marche pas c'est normal.

Par contre je ne comprends pas, en faisant ces modifs, j'arrive à me connecter par l'interface "internet" mais pas en lan.... ça voudrait dire que malgré la nouvelle IP, je me connecte toujours en lan? (càd mon jeu chercher d'abord le serveur sur le réseau local)

Tout ça est pour info, je laisse tout tomber jusqu'à avoir un routeur qui gère le loopback, trop chiant sinon  :D

#47 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 20 octobre 2007 - 14:45

Citation

Par contre je ne comprends pas, en faisant ces modifs, j'arrive à me connecter par l'interface "internet" mais pas en lan.... ça voudrait dire que malgré la nouvelle IP, je me connecte toujours en lan? (càd mon jeu chercher d'abord le serveur sur le réseau local)
non, ça veut dire qu'avec ta modif, ça marche en internet (mais que pour toi) et plus en LAN.
Plus en LAN probablement parce que le serveur "écoute" sur l'ip ajoutée, et que la recherche de serveur local se fait sur l'ip principale. En LAN mais en spécifiant l'ip de connexion (option /join=ip de TmUnited.exe) ça marcherait probablement toujours, c'est la recherche de serveur qui ne marche plus. Enfin c'est ce que l'effet me fait penser hein, difficile d'être sur même avec la  machine sous la main dans ce genre de cas  ;)

#48 OFFLINE   pingouin fripé

pingouin fripé

    Nouveau en confiance

  • Membres
  • 18 messages
  • Locationidf

Posté 27 dcembre 2007 - 09:17

J'aurais besoin d'un complément d'info pour ce tuto (ben oui, je comprends vite mais faut expliquer longtemps).
Voilà: dans le cas d'un modem-routeur (box), en plus de configurer l'IP fixe sur le pc où tourne le jeu et le serv, j'imagine qu'il faut également désactiver le DHCP dans le menu du routeur ?
Si oui, faut-il définir une régle d'attribution des adresses IP des pc connectés au routeur dans le menu du routeur ? Y'a-t-il une feinte à ce niveau ?

Question subsidiaire: admettons que je laisse tomber et que je reste connecté à mon serv en LAN, est-il normal que personne ne puisse voir mes skins (je précise que tous les ports jeux et serveur sont bien ouvert dans le fire-wall du routeur et que le fw de winXP est dégagé) ?

quoi, comment ça achète-toi "le réseau pour les nuls" ?  [ouf]

#49 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 27 dcembre 2007 - 11:17

Citation

Voilà: dans le cas d'un modem-routeur (box), en plus de configurer l'IP fixe sur le pc où tourne le jeu et le serv, j'imagine qu'il faut également désactiver le DHCP dans le menu du routeur ?
non, aucune raison de désactiver le dhcp du routeur, mais par contre il vaut mieux donner à ta machine une ip (dernier chiffre) qui ne soit pas dans la tranche d'ip du dhcp, ou en tout cas pas dans les 1ers numéros de la tranche, afin qu'une autre machine ne se retrouve pas avec la même ip.

Citation

Question subsidiaire: admettons que je laisse tomber et que je reste connecté à mon serv en LAN, est-il normal que personne ne puisse voir mes skins (je précise que tous les ports jeux et serveur sont bien ouvert dans le fire-wall du routeur et que le fw de winXP est dégagé) ?
Non, pas normal...
Le firewall du modem-routeur ça se déactive : ça sert à rien à part bloquer des trucs que tu veux pas, et de toute manière les machines dernière ne sont pas joignables sauf quand tu configure spécifiquement des redirections de ports.
D'ailleurs dans ton cas, il faut justement faire les redirections des ports qu'il faut* vers l'ip de ta machine, c'est d'ailleurs pour ça qu'il faut de toute manière un ip fixe afin qu'elle ne change pas.

(*) port p2p du jeu en tcp, pour faire serveur port principal du jeu en tcp et udp.

#50 OFFLINE   pingouin fripé

pingouin fripé

    Nouveau en confiance

  • Membres
  • 18 messages
  • Locationidf

Posté 27 dcembre 2007 - 12:11

Citation

non, aucune raison de désactiver le dhcp du routeur, mais par contre il vaut mieux donner à ta machine une ip (dernier chiffre) qui ne soit pas dans la tranche d'ip du dhcp, ou en tout cas pas dans les 1ers numéros de la tranche, afin qu'une autre machine ne se retrouve pas avec la même ip.
Bon OK, mais le truc c'est qu'hier soir j'avais configuré comme ça, avec une IP fixe avec un n° élevé, j'avais ajouté l'adresse publique comme précisé initialement et laissé la box en DHCP. Je pouvais me connecter en internet sur le serv mais plus personne d'autre  :?

Citation

Non, pas normal...
Le firewall du modem-routeur ça se déactive : ça sert à rien à part bloquer des trucs que tu veux pas, et de toute manière les machines dernière ne sont pas joignables sauf quand tu configure spécifiquement des redirections de ports.
D'ailleurs dans ton cas, il faut justement faire les redirections des ports qu'il faut* vers l'ip de ta machine, c'est d'ailleurs pour ça qu'il faut de toute manière un ip fixe afin qu'elle ne change pas.

(*) port p2p du jeu en tcp, pour faire serveur port principal du jeu en tcp et udp.

Euh, il me semblait moins con d'activer le fw du routeur et virer la passoire de XP (y'a qu'à faire un scan de port pour voir la différence), mais je peux me gourrer. Donc j'ai bien ouvert dans le fw les ports du jeu et du serveur. Ca a quand même l'air de marcher partiellement vu que les autres joueurs peuvent se connecter (quand je laisse tout en DHCP) et qu'ils arrivent bien à scanner les locators des ziks sur mon PC (ce qui confirme au passage que mon ftp fonctionne). Par contre, ils sont incapables de downloader mes skins qui sont sur le même ftp.

EDIT: en y repensant, je crois que j'ai compris, il s'agit principalement d'un gros problème de boulitude (du verbe être un boulet). Dans un 1er temps j'ai donc passé mon adresse IP locale en fixe (ex 192.168.1.100). Les ports du routeur étaient bien ouverts mais, et c'est probablement là la connerie, il fallait penser à les rediriger sur la nouvelle adresse IP locale, ce que j'avais oublié bien sûr.
Je sais pas si ça explique pourquoi moi j'arrivais à me connecter en internet, par contre ça explique pourquoi les autres n'y arrivaient pas.
Je reteste ça dans la soirée.

EDIT 2: problème réglé --> pour tous ceux qui ont un problème: ne pas oublier les redirections après fixation de l'adresse IP  :mrgreen:




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)