Aller au contenu


Erreurs lors de login

Bienvenue sur les nouveaux forums. Si vous avez des problèmes pour vous connecter avec votre login, certains caractères spéciaux présents dans les logins ont été modifiés dans le processus de migration, les logins avec les caractères "["
et "]" ont été remplacés par "!" par exemple. Vous pouvez aussi utiliser le formulaire de recouvrement de mot de passe avec votre adresse mail.

Il est également possible que des mots de passes aient été convertis lors de la migration, dans ce cas il vous suffit de redemander un mot de passe pour le réinitialiser.

Merci de votre compréhension ! :love:

[TUTO]Se connecter à son serveur dédié en mode internet


  • Veuillez vous connecter pour répondre
178 réponses à ce sujet

#51 OFFLINE   newpti

newpti

    Nouveau en confiance

  • Membres
  • 27 messages

Posté 24 janvier 2008 - 10:51

Salut à tous et à tous ceux pui pourront m'apporter leur lumière (Slig et autres ;) )

Alors voilà, j'avais un modem de base sous le quel tout était OK, tant sur TMN (skins...) que sur Servermania ou j'hébergeais de temps en temps un serveur pour ma team...
Puis je suis passé chez Alice et sa fameuse Alice Box... alors j'ai posté ceci car je ne pouvais plus lancer mon serveur http://www.trackmani...p=535091#535091 ce qui m'a rendu vers ton tutos Slig.
Ainsi j'ai effectué tout ce dont tu parlais avec l'affectation d'une ip fixe sur mon pc qui héberge le serveur. Servermania ne m'affiche plus l'erreur pour laquelle j'avais posté le topic (donc déjà c'est un point positif ;) ). Je peux me connecter SUR LE MÊME PC qui héberge le server à TMN et à mon serveur. Mais... pas sur mon autre PC. (connexion closed, erreur 10061)

Que dois-je faire? sachant que si je ne peux me connecter, mes collègues ne pourrons pas non-plus :(

:roll: je suis un peu perdu :(
I need Help please :wink:


#52 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 24 janvier 2008 - 15:02

Tu as fait quelle manip sur la machine faisant serveur ?  tu y as ajouté ton ip publique ?
Et si oui, quelle manip de la section "Si le jeu est sur une autre machine" as tu tenté ? es tu sur de ne pas avoir un firewall sur une des 2 machines qui bloque le dialogue entre les 2 ?

#53 OFFLINE   newpti

newpti

    Nouveau en confiance

  • Membres
  • 27 messages

Posté 24 janvier 2008 - 16:57

Merci Slig de ta réponse ;)
Alors,
sur le Pc1 (Bureau + jeu): j'ai mis mon adresse publique "Votre IP publique est : 83.157.137.167" + un ip fixe 192.168.1.2
Sur le Pc2 (celui qui héberge servermania) : j'ai remis mon ip publique "Votre IP publique est : 83.157.137.167" + un ip fixe 192.168.1.3
En fait pour les deux machines j'ai suivi le tutos "serveur sous windows"

Ensuite, dans la section "Si le jeu est sur une autre machine", je n'es rien tenté car je ne comprends pas en fait pour être franc :oops: .

D'après toi quelle manip dois-je faire?
Et j'ai une question idiote, le fait de faire une "route" ... mes collègues pourront rentrer sur le serveur? Pourrais-je jouer à partir de la machine ayant le serveur?

N'hésite pas à me  [mdr]  car je le mérite ;) lol.

Merci pour ton aide et j'attends ta réponse


#54 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 25 janvier 2008 - 19:45

heu non, sur la 2eme machine tu peux pas y mettre aussi ton ip publique (il rale pas d'ailleurs qu'elle existe déjà ???), par contre tu peux essayer en mettant sur la 2eme machine une ip "proche", genre 83.157.137.168 (ça correspond au 1er cas de "Si le jeu est sur une autre machine")

#55 OFFLINE   newpti

newpti

    Nouveau en confiance

  • Membres
  • 27 messages

Posté 25 janvier 2008 - 20:40

Je vais essayer ca mais mon IP publique n'est pas la même qu'importe les pc à partir du moment où l'on est connecté au net via 1 FAI et 1 Ligne téléphonique?  :roll:

Et j'ai une question idiote, le fait de faire une "route" ... mes collègues pourront rentrer sur le serveur? Pourrais-je jouer à partir de la machine ayant le serveur?

A bientôt Slig ;)
Merci de ton aide [merci]


#56 OFFLINE   Slig

Slig

    Prophète TM

  • Membres
  • PipPipPipPipPipPipPipPipPip
  • 3 425 messages
  • LocationTraXicoLand

Posté 26 janvier 2008 - 00:14

Citation

[color=darkblue]Je vais essayer ca mais mon IP publique n'est pas la même qu'importe les pc à partir du moment où l'on est connecté au net via 1 FAI et 1 Ligne téléphonique?  :roll:
Je suis pas sur de comprendre ta question, je pense que oui mais je réponds peut être à coté...

Le dialogue entre tes machines et ton routeur continuent à se faire avec l'ip 192.168.1.x, et dans tous les cas vu de l'extérieur ton ip sera toujours la même. Le fait d'ajouter une ip supplémentaire au machines à l'intérieur n'a d'impact que à l'intérieur, et ne peut normalement poser problème que dans un cas exceptionnel : si tu essaies de te connecter à une machine en 83.157.137.x (dans ton cas) tu ne pourras pas car ta machine croit que ce réseau est chez toi et pas à l'extérieur. Pas de panique : les ip concernées sont celles de 252 personnes maxi chez le même FAI que toi.
Eventuellement cette zone masquée peut être réduite avec un masque plus grand (exemple 255.255.255.240), mais ça dépend du dernier chiffre de l'ip, donc à moins de connaitre il vaut mieux en rester au masque 255.255.255.0.

Citation

Et j'ai une question idiote, le fait de faire une "route" ... mes collègues pourront rentrer sur le serveur? Pourrais-je jouer à partir de la machine ayant le serveur?
La route sur la 2eme machine (donc à la place d'y mettre une 2eme ip en 83.157.137.x dans ton cas) ne change rien au fonctionnement du reste, et offre l'avantage (faible) de ne pas masquer des ip extérieures contrairement à la technique de l'ip supp.

En résumé:
Si j'ai bien compris ton cas, sur la machine sur laquelle tu lance le serveur (192.168.1.3), tu dois ajouter l'ip 83.157.137.167
Et sur l'autre machine (192.168.1.2), tu ajoute une route statique avec la commande :  route add 83.157.137.167 192.168.1.3
Et évidement ça suppose que ton serveur fonctionne déjà correctement (donc joignable par des joueurs extérieurs), et ne pas avoir de firewall qui bloque le dialogue entre les 2 machines...

#57 OFFLINE   newpti

newpti

    Nouveau en confiance

  • Membres
  • 27 messages

Posté 26 janvier 2008 - 12:39

Bon alors...
Effectivement tu as bien saisi mon charabia [mdr] ;
J'ai donc mis une adresse sur la machine sur laquelle je lance le serveur (192.168.1.3), l'ip 83.157.137.167
Et sur l'autre machine (192.168.1.2), j'ai ajouté une route statique avec la commande : route add 83.157.137.167 192.168.1.3

Maintenant j'ai lancé servermania sur machine 2 et ai voulu me connecté à partir de la machine 1 (celle où j'ai rajouté la route)... même problème de connexion impossible erreur 10061). Le souci est que je ne peux pas savoir si mes collègues peuvent se connectés.
En revanche sans serveurmania, j'ai créé un petit serveur avec les outils de TMN, et 1 personne c'est joint à moi sur celui-ci, mais pas mon 2 ème cpt sur ma 2émé machine. Donc je présume que l'on peut se connecté sur mon server mais.. pas moi. Voilà mon souci désormais.

Merci de ton aide mais je comprendrai si tu te tirais une balle dans la tête à ta main ;)


#58 OFFLINE   Gangsta¤Bios

Gangsta¤Bios

    Il n'est plus un nouveau

  • Membres
  • 58 messages
  • Location41

Posté 01 mars 2008 - 18:11

bonjour

je suis avec une inventel de cegetel, un pc  sur lequel j'ai trackmania nation  et le serveur dédié(le serveur dedié fonctionne sans problème).

j'ai réalisé tous ce qui est dit dans le tuto mais je n'arrive toujour pas a me connecter par internet.

peut on m'aidé?
quelqu'un a t'il eu le même problème?
¤FMV¤Bios

#59 OFFLINE   gab-34

gab-34

    Il n'est plus un nouveau

  • Membres
  • 55 messages
  • LocationVers montpellier (34)

Posté 20 mars 2008 - 23:23

Merci beaucoup ça marche super
Tres sympa :)

#60 OFFLINE   fouizlala

fouizlala

    Il n'est plus un nouveau

  • Membres
  • 57 messages

Posté 03 avril 2008 - 11:15

Salut,

Alors avant tout merci pour ce tuto, très bien fait.

Mon problème est un peu différent.
Je suis chez noos/numéricable, j'arrive à faire fonctionner mon server mais je ne peux me connecter que par le réseau local, car par internet j'ai un message "je suis déjà connecté".

En effet en laissant mes réglages par défaut ou en faisant les réglages manuellement dans les propriétés réseau j'e ne fais que la même chose puisque mon adresse ip est  d'emblée l'ip publique (81.64.xxx.xx).

Du coup mon server utilise cette adresse et trackmania aussi.
J'ai l'impression que par le cable je n'ai en fait pas de routeur.

Je suis un peu un noob, j'éspères que je vous explique correctement le problème et qu'il y a une solution.

Merci  :)

#61 OFFLINE   twister_56

twister_56

    Respectable Ancien

  • Membres
  • PipPipPipPipPipPip
  • 1 299 messages
  • LocationProche de Nantes :P

Posté 03 avril 2008 - 18:23

Salut à toi  :wink:

Il ne faut surtout pas que le login de ton serveur soit le même que celui de ton serveur.

C'est un serveur TMU ou TMN ? (TMU j'ai quelques trou, je me souvient pas de tout   :mrgreen: )
Image IPB
*** [SYR] : Ne jouez pas contre mais avec les autres ! ***
Image IPB

#62 OFFLINE   fouizlala

fouizlala

    Il n'est plus un nouveau

  • Membres
  • 57 messages

Posté 03 avril 2008 - 18:52

Alors c'est un server Nations.
J'ai aussi United mais au final j'y joue presque jamais.

Sinon je n'avais pas précisé mais mon server est sur Servermania 0.90.


Donc si je te suis bien il faut que je créé un compte spécialement pour le server c'est ca ?


Ah! Et aussi même quand les gens se connectent, un message leur stipule qu'il y a un soucis et que seules les données TCP sont transmises, et pas les UDP. C'est un peu ennuyeux car du coup les personnalisations de voitures etc sont absentes.


Merci pour ta réponse rapide sinon. :)

#63 OFFLINE   twister_56

twister_56

    Respectable Ancien

  • Membres
  • PipPipPipPipPipPip
  • 1 299 messages
  • LocationProche de Nantes :P

Posté 03 avril 2008 - 19:00

Quel pare feu utilise tu ?
Sous quel FAI es-tu ?
Et quels sont les ports que tu utilises pour le serveur ? :wink:
Image IPB
*** [SYR] : Ne jouez pas contre mais avec les autres ! ***
Image IPB

#64 OFFLINE   fouizlala

fouizlala

    Il n'est plus un nouveau

  • Membres
  • 57 messages

Posté 03 avril 2008 - 19:46

Firewall : ZoneAlarm free

FAI : noos

Les ports : 2352 & 3452 mais au début je mettais 2351 & 3451 et ca n'a rien changer, ca marche mais pas l'UDP et je ne peux me connecter que par le local dans les deux cas.

#65 OFFLINE   fouizlala

fouizlala

    Il n'est plus un nouveau

  • Membres
  • 57 messages

Posté 03 avril 2008 - 23:45

Bon alors ca a l'air de fonctionner nikel !

J'ai juste créé un autre compte dans Trackmania puis affecté ce compte au server.

Ensuite je peux me connecter avec mon autre compte via internet et donc le ladder  [clap]

C'est donc finalement beaucoup plus simple via un opérateur câble.
Merci beaucoup !
Je n'avais pas du tout pensé aux deux comptes différents pour le server et le jeu...

Salut !

#66 OFFLINE   fouizlala

fouizlala

    Il n'est plus un nouveau

  • Membres
  • 57 messages

Posté 04 avril 2008 - 01:18

... c'est encore moi.

Alors ca marche nikel dans le sens ou je peux me connecter via internet.
En revanche les gens se connectants ont toujours le message "TCP ok UDP non" (en substance).

Auriez vous une idée de ce qui peut provoquer cela ?

En plus de ZoneAlarm j'ai également la protection résidente d'Avast!
Le problème pourrait venir ses boucliers "réseau" ou "standard" ?

Ou du fait que le compte server et le compte jeu utilisent la meme ip ?




PS: sur ce bonne nuit à vous

#67 OFFLINE   twister_56

twister_56

    Respectable Ancien

  • Membres
  • PipPipPipPipPipPip
  • 1 299 messages
  • LocationProche de Nantes :P

Posté 04 avril 2008 - 05:16

Ton pare feu ne bloquerai t-il pas les port en UDP ?
Image IPB
*** [SYR] : Ne jouez pas contre mais avec les autres ! ***
Image IPB

#68 OFFLINE   Tati Trini

Tati Trini

    Guide de la nation TM

  • Gentils Modérateurs
  • PipPipPipPipPipPipPipPipPipPip
  • 17 823 messages
  • LocationAu bord de la mer...

Posté 04 avril 2008 - 09:52

phonic_sp a écrit:
AH j'ai peut-être trouvé !!!!!!
j'ai trouvé un "mode jeu" dans zone alarme qui supprime temporairement les alertes. J'ai fais 2 essais et ça a marché nickel les 2 fois.
Ce qui m'étonne c'est que ça n'est pas marché quand j'ai désactivé zone alarme (ou alors il restait des processus en marche). :wink:
Faq et Wiki à lire avant de poser une question.  

Focus ! Nadeo ! We love you ! Trackmania Forever and ever !

Image IPB

#69 OFFLINE   fouizlala

fouizlala

    Il n'est plus un nouveau

  • Membres
  • 57 messages

Posté 04 avril 2008 - 11:00

Effectivement j'utilise jamais le mode jeu.
Je vais essayer.

Sinon y a-t-il moyen d'entrer une règle pour ouvrir les ports UDP dans ZoneAlarm ?

#70 OFFLINE   Tati Trini

Tati Trini

    Guide de la nation TM

  • Gentils Modérateurs
  • PipPipPipPipPipPipPipPipPipPip
  • 17 823 messages
  • LocationAu bord de la mer...

Posté 04 avril 2008 - 13:29

je n'ai pas zonealarm...
Faq et Wiki à lire avant de poser une question.  

Focus ! Nadeo ! We love you ! Trackmania Forever and ever !

Image IPB

#71 OFFLINE   nico51

nico51

    Nouveau en confiance

  • Membres
  • 16 messages

Posté 06 avril 2008 - 13:29

BONJOUR JE VOUDRAI SAVOIR COMMENT ON PEUT OUVRIR LES POSTE AVEC ALICE  MERCI DE  VOTRE  COMPREENSION :-o
NICO

#72 OFFLINE   Tati Trini

Tati Trini

    Guide de la nation TM

  • Gentils Modérateurs
  • PipPipPipPipPipPipPipPipPipPip
  • 17 823 messages
  • LocationAu bord de la mer...

Posté 06 avril 2008 - 14:34

bonjour et bienvenue. :D

http://www.trackmani...pic.php?t=24915 second post

les majuscules sur un forum ne sont pas les bienvenues...  :wink:
Faq et Wiki à lire avant de poser une question.  

Focus ! Nadeo ! We love you ! Trackmania Forever and ever !

Image IPB

#73 OFFLINE   Monster_kill

Monster_kill

    Il n'est plus un nouveau

  • Membres
  • 60 messages

Posté 19 avril 2008 - 11:07

Bonjour à tous,

J'ai le même problème alors je vais essayer d'être le plus précis possible dans la description de mon problème :

Système d'exploitation utilisé : Linux

Serveur dédié : Trackmania United

FAI : Alice Box

Ports des serveurs NAT :

1er : Nom du serveur : Trackmania Non prédéfini dans l'alice box ; Port extérieur Début : 2351 ; Port extérieur Fin : 2352 ; Protocole : TCP/UDP ; Port interne Début : 2351 ; Port interne Fin 2352;
2ème : Nom du serveur : Trackmania  Non prédéfini dans l'alice box ; Port extérieur Début : 3451 ; Port extérieur Fin : 3452 ; Protocole : TCP/UDP ; Port interne Début : 3451 ; Port interne Fin 3452;
Adresse IP du poste serveur : Celle de la machine qui créé le serveur.

Ports dans le dedicated du dédié :
2352
3452


Ports dans la config de TMUF : Server port 2350; Server p2p port 3450

Mon adresse IP publique change je ne sais pas si c'est ça qui pose problème.

Voici un screenshot de qui se passe quand j'essaye de me connecter :
Image IPB
Je pense qu'il n'y a aucun conflit de ports puisque qu'ils sont tous différents l'un de l'autre. Ce qui pourrait donc être une histoire de compte : Impossible puisque j'ai fais un compte dédié au serveur et que je l'ai précisé dans le dedicated.

Remarque : Tous les joueurs peuvent se connecter à part moi...

Au secours ...   [snif]  [snif]

Merci de m'aider  :)

#74 OFFLINE   ß@ұ°NiTro

ß@ұ°NiTro

    Nouveau en confiance

  • Membres
  • 10 messages

Posté 21 avril 2008 - 19:13

vous auriez pas un tuto complet depuis le debut svp pour creer un serveur avec aseco svp je suis en galere

#75 OFFLINE   twister_56

twister_56

    Respectable Ancien

  • Membres
  • PipPipPipPipPipPip
  • 1 299 messages
  • LocationProche de Nantes :P

Posté 21 avril 2008 - 19:20

http://www.trackmani...opic.php?t=6301
http://www.trackmani...pic.php?t=22401
http://www.trackmani...pic.php?t=26055
http://farfane.free.fr/
:wink:
Image IPB
*** [SYR] : Ne jouez pas contre mais avec les autres ! ***
Image IPB




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)